If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox 17 (upgrade from 15) does not have imported bookmarks on launch; relaunch restores them

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: Jesse Moorman, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

Upgrade from 15 to 17


Actual results:

First launch did not have imported bookmarks. (I've used Mozilla since original beta test days, and never had this problem, so I think it may be inherent in Firefox 17.) Relaunch checked again for add-on compatibility and then Firefox did have the bookmarks.


Expected results:

Firefox should complete the import of bookmarks before first launch. It is a bit frightening, and not easy to find an answer. Fortunately I did not waste time looking for an answer, but I see, from searching now for help and for bugs, that the search might be a problem.
A new version doesn't import the bookmarks, it just uses the file that the old version already used.
This works as expected, import bookmarks dialog appears only at first lunch afterwords when you upgrade firefox just use the file from your profile.

http://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.