Closed Bug 815054 Opened 8 years ago Closed 8 years ago

Library window is stealing focus of browsing window

Categories

(Firefox :: Bookmarks & History, defect)

20 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 768802

People

(Reporter: Virtual, Unassigned)

Details

(Keywords: nightly-community)

1. Open Nightly
2. Open Library
3. Close Nightly browse window, so only Library will be opened
4. Start opening some bookmarks from Library
5. and try normally browse the web with Library window in background

in near time you will see that Library window will steal focus and will go to first plan
I don't remember any recent change made to the Library or its focus off-hand.
dupe of bug 812892, but much worse with Windows 8, as any window can steal focus.
I'm not so sure there is a regression window to be found.  On Windows 8, I went as far back as Firefox 4 beta and the issue is still reproducible.  There is simply an inherent flaw that needs fixing.
Yep, looks like a dupe of bug #812892.

I migrated to 32bit Nightly build from 64bit on my Win7 64bit as 64bit will be on hiatus and I can't remember that I was having this issue on 64bit Nightlys. That's why I marked this bug as "regression" as I was thinking it regressed when I was changing builds. ;d
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Hardware: x86 → x86_64
Resolution: --- → DUPLICATE
Duplicate of bug: 812892
I forgot to add that I can't find regression range as it happens also in earliest tinderbox-builds/mozilla-inbound-win32-pgo, so it's clearly a dupe of bug #812892
You need to log in before you can comment on or make changes to this bug.