Intermittent crash 'Main app process exited normally' [@ msvcr100.dll@0x8af06 | soundtouch::RateTransposer::processSamples(float const *,unsigned int)]

RESOLVED DUPLICATE of bug 814708

Status

()

--
critical
RESOLVED DUPLICATE of bug 814708
6 years ago
6 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
x86
Windows 7
crash, intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
Rev3 WINNT 6.1 mozilla-inbound opt test mochitest-1 on 2012-11-25 09:06:21 PST for push e390f459239e

slave: talos-r3-w7-042

https://tbpl.mozilla.org/php/getParsedLog.php?id=17332149&tree=Mozilla-Inbound

{
130378 INFO TEST-PASS | /tests/content/media/test/test_playback_rate.html | playbackRate should be reset to 1.0 on play() call
TexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
Can't find symbol 'GetTexImage'
Can't find symbol 'GetTexLevelParameteriv'
INFO | automation.py | Application ran for: 0:14:32.522000
INFO | automation.py | Reading PID log: c:\users\cltbld\appdata\local\temp\tmpn3narupidlog
==> process 1524 launched child process 1944
==> process 1524 launched child process 292
==> process 1524 launched child process 2132
==> process 1524 launched child process 3568
INFO | automation.py | Checking for orphan process with PID: 1944
INFO | automation.py | Checking for orphan process with PID: 292
INFO | automation.py | Checking for orphan process with PID: 2132
INFO | automation.py | Checking for orphan process with PID: 3568
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1353859505/firefox-20.0a1.en-US.win32.crashreporter-symbols.zip
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpqxf1af\minidumps\63d70462-8ba0-4e36-9d1f-1c339536ab11.dmp
Operating system: Windows NT
                  6.1.7600 
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXCEPTION_NONCONTINUABLE_EXCEPTION
Crash address: 0x0
Assertion: Pure virtual function called

Thread 46 (crashed)
 0  msvcr100.dll + 0x8af06
    eip = 0x6fd3af06   esp = 0x1851fd90   ebp = 0x1851fda4   ebx = 0x00000000
    esi = 0x01a290c0   edi = 0x00001140   eax = 0x1851f760   ecx = 0x1851fa2c
    edx = 0x00000000   efl = 0x00000202
    Found by: given as instruction pointer in context
 1  soundtouch.dll!soundtouch::RateTransposer::processSamples(float const *,unsigned int) [RateTransposer.cpp:e390f459239e : 304 + 0x4]
    eip = 0x6fe61c01   esp = 0x1851fdac   ebp = 0x1851fdbc
    Found by: previous frame's frame pointer
 2  soundtouch.dll!soundtouch::SoundTouch::putSamples(float const *,unsigned int) [SoundTouch.cpp:e390f459239e : 324 + 0x17]
    eip = 0x6fe61e91   esp = 0x1851fdc4   ebp = 0x1851fdd0
    Found by: call frame info
 3  xul.dll!mozilla::nsBufferedAudioStream::GetTimeStretched(void *,long) [AudioStream.cpp:e390f459239e : 989 + 0x21]
    eip = 0x6c4681bc   esp = 0x1851fdd8   ebp = 0x1851fe0c
    Found by: call frame info
 4  xul.dll!mozilla::nsBufferedAudioStream::DataCallback(void *,long) [AudioStream.cpp:e390f459239e : 1014 + 0x4]
    eip = 0x6c46825e   esp = 0x1851fe14   ebp = 0x1851fe30
    Found by: call frame info
 5  xul.dll!mozilla::nsBufferedAudioStream::DataCallback_S(cubeb_stream *,void *,void *,long) [AudioStream.cpp:e390f459239e : 616 + 0xd]
    eip = 0x6c468302   esp = 0x1851fe38   ebp = 0x1851fe40
    Found by: call frame info
 6  gkmedias.dll!cubeb_refill_stream [cubeb_winmm.c:e390f459239e : 124 + 0xe]
    eip = 0x6e2cf24b   esp = 0x1851fe48   ebp = 0x1851fe70
    Found by: call frame info
 7  gkmedias.dll!cubeb_buffer_thread [cubeb_winmm.c:e390f459239e : 164 + 0x7]
    eip = 0x6e2cf376   esp = 0x1851fe78   ebp = 0x1851fe84
    Found by: call frame info
 8  msvcr100.dll + 0x5c6dd
    eip = 0x6fd0c6de   esp = 0x1851fe8c   ebp = 0x1851febc
    Found by: call frame info
 9  msvcr100.dll + 0x5c787
    eip = 0x6fd0c788   esp = 0x1851fec4   ebp = 0x1851fec8
    Found by: previous frame's frame pointer
10  kernel32.dll + 0x51173
    eip = 0x76ef1174   esp = 0x1851fed0   ebp = 0x1851fed4
    Found by: previous frame's frame pointer
11  ntdll.dll + 0x5b3f4
    eip = 0x7740b3f5   esp = 0x1851fedc   ebp = 0x1851ff14
    Found by: previous frame's frame pointer
12  ntdll.dll + 0x5b3c7
    eip = 0x7740b3c8   esp = 0x1851ff1c   ebp = 0x1851ff2c
    Found by: previous frame's frame pointer
}

Comment 3

6 years ago
Hopefully the fix for bug 814708 will help here as all. Also bug 495040 is more likely to be related than 810262.
Blocks: 495040
Depends on: 814708
Closing this for now, as Jacek is likely to have fixed the issue with his patch on bug 814708.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 814708
You need to log in before you can comment on or make changes to this bug.