Closed Bug 815123 Opened 7 years ago Closed 7 years ago

Intermittent crashtests/481921.html | assertion count 1 is more than expected 0 assertions ("ASSERTION: RECURSION_LEVEL(table_) > 0: 'RECURSION_LEVEL(table) > 0', file pldhash.cpp, line 670")

Categories

(Core :: Audio/Video, defect, critical)

x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 651615

People

(Reporter: emorley, Unassigned)

References

Details

(Keywords: assertion, intermittent-failure)

Rev3 Fedora 12x64 mozilla-inbound debug test crashtest on 2012-11-25 15:53:04 PST for push 4b816b309e52

slave: talos-r3-fed64-064

https://tbpl.mozilla.org/php/getParsedLog.php?id=17335317&tree=Mozilla-Inbound

{
REFTEST TEST-START | file:///home/cltbld/talos-slave/test/build/reftest/tests/layout/generic/crashtests/481921.html | 1319 / 2151 (61%)
++DOMWINDOW == 19 (0x65ca2f0) [serial = 3098] [outer = 0x2a380b0]
++DOCSHELL 0x6736940 == 4 [id = 198]
++DOMWINDOW == 20 (0x6e19680) [serial = 3099] [outer = (nil)]
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv) && subjPrincipal) failed: file ../../../docshell/base/nsDocShell.cpp, line 8201
WARNING: Subdocument container has no frame: file ../../../layout/base/nsDocumentViewer.cpp, line 2400
++DOMWINDOW == 21 (0x33944e0) [serial = 3100] [outer = 0x6e19600]
###!!! ASSERTION: RECURSION_LEVEL(table_) > 0: 'RECURSION_LEVEL(table) > 0', file pldhash.cpp, line 670
std::map<ogg_packet*, long, std::less<ogg_packet*>, std::allocator<std::pair<ogg_packet* const, long> > >::operator[](ogg_packet* const&) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
std::map<ogg_packet*, long, std::less<ogg_packet*>, std::allocator<std::pair<ogg_packet* const, long> > >::operator[](ogg_packet* const&) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
std::map<ogg_packet*, long, std::less<ogg_packet*>, std::allocator<std::pair<ogg_packet* const, long> > >::operator[](ogg_packet* const&) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
std::map<ogg_packet*, long, std::less<ogg_packet*>, std::allocator<std::pair<ogg_packet* const, long> > >::operator[](ogg_packet* const&) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JSPrincipals::dump() (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
std::vector<bool, std::allocator<bool> >::~vector() (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
NS_InvokeByIndex_P (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
xpc_LocalizeContext(JSContext*) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
xpc_LocalizeContext(JSContext*) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
xpc_LocalizeContext(JSContext*) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JS_EnumerateDiagnosticMemoryRegions(int (*)(void*, unsigned long)) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JS_EnumerateDiagnosticMemoryRegions(int (*)(void*, unsigned long)) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JS_EnumerateDiagnosticMemoryRegions(int (*)(void*, unsigned long)) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JS_EnumerateDiagnosticMemoryRegions(int (*)(void*, unsigned long)) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
js_DumpBacktrace(JSContext*) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
js_DumpBacktrace(JSContext*) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
js_DumpBacktrace(JSContext*) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
js_DumpBacktrace(JSContext*) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JS_EnumerateDiagnosticMemoryRegions(int (*)(void*, unsigned long)) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JS_EnumerateDiagnosticMemoryRegions(int (*)(void*, unsigned long)) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JS_EnumerateDiagnosticMemoryRegions(int (*)(void*, unsigned long)) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JS_EnumerateDiagnosticMemoryRegions(int (*)(void*, unsigned long)) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JS_EnumerateDiagnosticMemoryRegions(int (*)(void*, unsigned long)) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JS_CallFunctionValue(JSContext*, JSObject*, JS::Value, unsigned int, JS::Value*, JS::Value*) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
xpc_LocalizeContext(JSContext*) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
xpc_LocalizeContext(JSContext*) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
NS_InvokeByIndex_P (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
NS_InvokeByIndex_P (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
WARNING: NS_ENSURE_TRUE(txToRemove) failed: file ../../../../docshell/shistory/src/nsSHistory.cpp, line 1307
REFTEST TEST-PASS | file:///home/cltbld/talos-slave/test/build/reftest/tests/layout/generic/crashtests/481921.html | (LOAD ONLY)
REFTEST INFO | Loading a blank page
++DOMWINDOW == 22 (0x6cafe20) [serial = 3101] [outer = 0x2a380b0]
REFTEST TEST-UNEXPECTED-FAIL | file:///home/cltbld/talos-slave/test/build/reftest/tests/layout/generic/crashtests/481921.html | assertion count 1 is more than expected 0 assertions
}
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 651615
You need to log in before you can comment on or make changes to this bug.