Sounds associated with Notifications

RESOLVED DUPLICATE of bug 809680

Status

Firefox OS
Gaia
P1
normal
RESOLVED DUPLICATE of bug 809680
5 years ago
5 years ago

People

(Reporter: mtreese, Unassigned)

Tracking

({feature})

unspecified
B2G C2 (20nov-10dec)
ARM
Other
feature

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

5 years ago
USER-SOUND-001	As a user I can hear sounds associated with notifications including new email and new sms messages.

Updated

5 years ago
Component: Gaia → Gaia::System
We might need separate bugs on each notification that should have sound. Casey, Chris, do either of you have a sense for which exact notifications need sound?

Or should we always play a sound when someone puts a notification in the notification tray?
Component: Gaia::System → Gaia
(In reply to Jonas Sicking (:sicking) from comment #1)
> We might need separate bugs on each notification that should have sound.
> Casey, Chris, do either of you have a sense for which exact notifications
> need sound?
> 
> Or should we always play a sound when someone puts a notification in the
> notification tray?

I don't think there's a good way to distinguish email/sms when system app gets the mozNotification. Even let email/sms to play sounds by their-self when they send notifications is not reasonable.

I am told by schung that for v1 email won't send any notification for new mail incoming. The use must click button to recieve mail.

But I think this doesn't matter with our decision here: simply apply sound to every notification. I've discussed this behavior with Casey during SFO work week and he agreed. For v1.
Chagning to C2 milestone since this is what everyone is tracking right now. Have it with C1 might miss it. But since this is a pending feature, should finish before end of C2.
Target Milestone: B2G C1 (to 19nov) → B2G C2 (20nov-10dec)
Seems like a duplicate of bug 809680. As Alive said this is not doable to disambiguish between 2 types of notification for now and the notification sound will be global.

Please re-open if you expect something different.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 809680

Comment 5

5 years ago
Agree with comment 2 here.  We'll have a general sound for notifications and not distinguish the source for v1.  

I've also updated the user story (USER-SOUND-001) to reflect this.
(In reply to Chris Lee [:clee] from comment #5)
> Agree with comment 2 here.  We'll have a general sound for notifications and
> not distinguish the source for v1.  
> 
> I've also updated the user story (USER-SOUND-001) to reflect this.

USER-SOUND-001 currently reads:
"As a user I can hear sounds associated with notifications including new email and new sms messages."

On bug 811704 is where we are covering e-mail's lack of sounds. (As things stand, there is no sound support and will be no sound support.)  While further action is currently blocked on feedback from Casey, if product could conclusively say something and maybe provide blocking approval or moot it for v1, that would probably be useful.
See Also: → bug 811704
You need to log in before you can comment on or make changes to this bug.