Closed Bug 815339 Opened 7 years ago Closed 7 years ago

[OS.File] Extract PromiseWorker from OS.File

Categories

(Toolkit :: OS.File, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: Yoric, Assigned: Yoric)

References

Details

Attachments

(1 file, 2 obsolete files)

Not sure yet how to approach bug 801598, but we can already extract the part of OS.File that wraps communication with a worker in promises, and this will be useful for bug 753768.
Assignee: nobody → dteller
Attachment #685324 - Flags: review?(nfroyd)
Comment on attachment 685324 [details] [diff] [review]
Extracting PromiseWorker from OS.File

Review of attachment 685324 [details] [diff] [review]:
-----------------------------------------------------------------

Even if we wind up doing something different, I think this is much cleaner.
Attachment #685324 - Flags: review?(nfroyd) → review+
Depends on: 817923
No longer depends on: 817923
Duplicate of this bug: 817923
Attachment #685324 - Attachment is obsolete: true
Attachment #692274 - Flags: review+
Unfortunately, this has bitrotted more than I'm comfortable fixing up myself. Please post a rebased patch.
Keywords: checkin-needed
Same one, minus bitrot.
Attachment #692274 - Attachment is obsolete: true
Attachment #693792 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/52b5ac587767
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Hey all -- doing some doc updating here. I see there's some documentation already created, and I'm updating and tidying that up, and I notice that it's importing PromiseWorker.js instead of PromiseWorker.jsm. Which are you supposed to use, or are both used but in different circumstances, or...?
PromiseWorker.js needs to be imported from the worker, while PromiseWorker.jsm needs to be imported from the main thread.
You need to log in before you can comment on or make changes to this bug.