Closed Bug 815501 Opened 7 years ago Closed 7 years ago

Installing an app with a developer property that only has a url or a name - undefined is seen in the install prompt

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jsmith, Assigned: MattN)

References

Details

Attachments

(1 file)

Build:

Device - Unagi

Hashes

  <project name="gaia" path="gaia" remote="b2g" revision="176aea9cba4965594350f282751758b14d2624fc"/>
  <project name="releases/gecko" path="gecko" remote="mozillaorg" revision="4eaacd3fad7b6da220de206c0013dc0f307455c9"/>

Steps:

1. Install an app with a developer property with name or url, but not both

Expected:

The author should be seen with the name or url only.

Actual:

The author name or url is present, but a word "undefined" is seen in the UI. We're probably not checking for if the value isn't present.

Doesn't block, given that this is an edge case, as typically the developer property either is entirely specified or not specified at all.
Blocks: app-install
Comment on attachment 690239 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6910

I ran the modified test but was not able to manually test.
Attachment #690239 - Flags: review?(etienne)
Assignee: nobody → mnoorenberghe+bmo
Status: NEW → ASSIGNED
You can use an app I worked on as a manual testcase as it doesn't have a developer url: https://marketplace.mozilla.org/app/slithering/
Comment on attachment 690239 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6910

small comment on github.
Attachment #690239 - Flags: review?(etienne) → review+
Comment on attachment 690239 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6910

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Described in description
User impact if declined: polish
Testing completed: tested on unagi
Risk to taking this patch (and alternatives if risky): low, small change with unit tests \o/
Attachment #690239 - Flags: approval-gaia-master?(21)
(In reply to Etienne Segonzac (:etienne) from comment #4)
> Comment on attachment 690239 [details]
> small comment on github.

Fixed in f2b01c2.  Thanks for the quick review.
Etienne/Vivien, is it normal that this patch has been waiting over a month for gaia approval? Is it not wanted in v1 because it's not bb+?
(In reply to Matthew N. [:MattN] from comment #7)
> Etienne/Vivien, is it normal that this patch has been waiting over a month
> for gaia approval? Is it not wanted in v1 because it's not bb+?

Probably slipped through the cracks by accident. Let's ping him directly.
Flags: needinfo?(21)
There is even worse than that, if you do not set `developer` field, the app won't install at all :/
I've opened bug 828280 in order to address that.
(In reply to Matthew N. [:MattN] from comment #7)
> Etienne/Vivien, is it normal that this patch has been waiting over a month
> for gaia approval? Is it not wanted in v1 because it's not bb+?

Yeah December was a pretty busy month so I prioritized blocking-basecamp+ bugs. This week is pretty busy too but we reach a stability point where I can look at other point again. Sorry for the delay though and thanks a lot for the patch and all the tests.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.