[SMS] Change condition in order to prevent Gecko bug

VERIFIED FIXED in B2G C2 (20nov-10dec)

Status

Firefox OS
Gaia::SMS
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: borjasalguero, Assigned: borjasalguero)

Tracking

unspecified
B2G C2 (20nov-10dec)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Due to https://bugzilla.mozilla.org/show_bug.cgi?id=808220 threads rendering is not working properly. In order to shield SMS App from this bug, we are going to come back to the previous condition, making it works as usual
(Assignee)

Updated

5 years ago
Assignee: nobody → fbsc
(Assignee)

Comment 1

5 years ago
Created attachment 685600 [details]
PR

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #685600 - Flags: review?(francisco.jordano)
Attachment #685600 - Flags: approval-gaia-master?(francisco.jordano)
Attachment #685600 - Flags: review?(francisco.jordano)
Attachment #685600 - Flags: review+
Attachment #685600 - Flags: approval-gaia-master?(francisco.jordano)
Attachment #685600 - Flags: approval-gaia-master+
(Assignee)

Comment 2

5 years ago
Merged

Comment 3

5 years ago
comment 0 indicates this blocks bug 808220.
Blocks: 808220
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 4

5 years ago
Unagi
56e45e8
4eaacd3

PROCEDURE
1. Open SMS app and send a message by typing the number. 
2. Do something while in SMS app, open edit mode, open another conversation...
3. Check the number to which you sent the message

ACTUAL
The sms destination number chages to +34863334633 (which is not a valid Spanish number, without +34, the number is the codification of the word undefined)

Comment 5

5 years ago
nom'ing based on comment 4.   the number shown is incorrect according to the tester.
blocking-basecamp: --- → ?
blocking-basecamp: ? → +
Priority: -- → P2
Target Milestone: --- → B2G C2 (20nov-10dec)

Comment 6

5 years ago
Reviewed and verified on "Unagi"
Build ID:2013010307201
SMS destination number didn't change if you in Edit mode, opening another conversation ...
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.