Merge the Places transactions manger to the window one

RESOLVED WONTFIX

Status

()

Toolkit
Places
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: mak, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
In order to move the Library in a tab, would make sense to merge transactions into the window transaction manager.
The problem is that most of our dialogs are instant-apply and we use transactions temporarily, on Canceling the dialog, we undo the transaction and there is concrete risk to cancel any other operation in the meanwhile. For example open properties of a bookmark, edit the title, do something else in browser window, cancel the bookmark dialog, lose all the changes.
One thing we may do is adding to transaction managers the possibility to inherit transactions without executing them, so we may use a temporary manager and when the dialog is confirmed transfer all the transactions to the main one.
(Reporter)

Comment 1

5 years ago
After discussing with Mano, looks like we don't need all of this, undo/redo may just use the current Places controller and transaction manager, if then we want to allow undo/redo bookmarks operations everywhere without being in the Library tab, that's another story and we already have a separate bug for that.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.