"Not loading properly" appears very often

VERIFIED FIXED in B2G C2 (20nov-10dec)

Status

P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: ranbena, Assigned: crdlc)

Tracking

unspecified
B2G C2 (20nov-10dec)
x86
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(2 attachments)

Comment hidden (empty)
blocking-basecamp: --- → ?
Many urls loaded from Evme end up with a "App is having problems".

Can be easily reproducible when clicking on the NY Times app.

1. On Evme, search for News.
2. Click on the black New York Times app (third row).
3. Immediately an error message appears.

Notice, the page loads from Gaia Firefox.
Assignee: nobody → crdlc
(Assignee)

Updated

6 years ago
Assignee: crdlc → nobody
(Assignee)

Comment 2

6 years ago
Hi Vivien, 

   I can reproduce the problem. It is strange because behind the overlay 'xxxx is not loading properly' I can see the web loaded :). Any idea?

Thanks
(Assignee)

Comment 3

6 years ago
We receive a mozbrowsererror whose type is 'other' :) in window_manager
(Assignee)

Comment 4

6 years ago
ok the problem is modal_dialog.js
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 5

6 years ago
Created attachment 685644 [details]
Patch v1
Attachment #685644 - Flags: review?(21)
blocking-basecamp: ? → +
Priority: -- → P2
Target Milestone: --- → B2G C2 (20nov-10dec)
Backed out for causing numerous regressions 

https://github.com/mozilla-b2g/gaia/commit/2d31d72d00ce6db960e8cb87600b16074d8e66c3
Status: RESOLVED → REOPENED
Depends on: 816295
Resolution: FIXED → ---
Patrick,
http://mobile.nytimes.com is fireing mozbrowsererror when first time loading. After reloading no error happens.
Could you help to distinguish what the exact error this is? Thank you.
(Assignee)

Comment 10

6 years ago
Created attachment 686510 [details]
Patch v2

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): regression of this bug
User impact if declined: several app don't load in wrapper
Testing completed: 
Risk to taking this patch (and alternatives if risky): IMHO with this patch no risk
Attachment #686510 - Flags: review?(alive)
Attachment #686510 - Flags: approval-gaia-master?(21)
Comment on attachment 686510 [details]
Patch v2

r=me, this is bb+ now.
Please keep in mind you should test your trivial patch which may cause non-trivial regression, from now on, every time. :)

Since this is a workaround, we should recover the error page in some day.
Attachment #686510 - Flags: review?(alive) → review+
Comment on attachment 686510 [details]
Patch v2

No need for approval since this blocks.
Attachment #686510 - Flags: approval-gaia-master?(21)
(Assignee)

Comment 13

6 years ago
uppss sorry
(Assignee)

Comment 14

6 years ago
https://github.com/mozilla-b2g/gaia/commit/115f0c4aa861cec845645c4c970f9bcc207bea5c
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Comment 15

6 years ago
Verified fixed on Unagi build 20130103070201. The NY Times page loaded properly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.