Font inflation causes position:fixed element to get mis-laid out

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: aschneider83, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 685653 [details]
Screenshot_2012-11-27-17-47-15.png

User Agent: Opera/9.80 (Android 4.0.3; Linux; Opera Mobi/ADR-1210241511) Presto/2.11.355 Version/12.10

Steps to reproduce:

Pls go to pickupforum.de, press "anmelden" to open login interface and compare attachement




Actual results:

see attachement


Expected results:

Iframe should be fitted correctly and not broken.
The "iframe" is really a position:fixed element. Font inflation seems to be the cause of the mis-rendering of the element; bumping the text size down to tiny fixes the look of the login element.
Blocks: 627842
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Iframe Login on some Sites is broken → Font inflation causes position:fixed element to get mis-laid out
Note that the positioning of the element seems to be fine (it behaves strangely but that's expected given we're rendering desktop-specific content on mobile); the only bug here is the rendering of the content inside the position-fixed element that shows up.
It is possible that this is a bug, but the dependency of the login screen's position on the screen size makes it difficult to tell. I recommend that we urge the site to fix their layout for mobile -- i.e. evangelize to this site that it's difficult to read on mobile. Then, if there are still bugs, we'll be able to tell, as the login screen will be positioned and sized correctly.

Note that this is not the only site that uses this position:fixed method of popup-style login screens, and I haven't heard of other sites having an issue with font inflation, but it could be they just haven't been reported yet.
Assignee: nobody → english-us
Component: Readability → English US
Product: Firefox for Android → Tech Evangelism
Version: Firefox 18 → unspecified
Assignee: english-us → german
Component: English US → German
(Reporter)

Comment 4

6 years ago
Thx for having a look at this.

Comment 5

5 years ago
Works fine on Desktop. Could someone test this with Android?
Flags: needinfo?
OS: Linux → Android
It's working fine in Desktop.
On Mobile, it's a different issue, Firefox for Android is receiving the desktop version and not the mobile version.
Assignee: german → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: German → Desktop
Flags: needinfo?
Resolution: --- → FIXED
Blocks: 1061031
You need to log in before you can comment on or make changes to this bug.