Closed Bug 815699 Opened 9 years ago Closed 9 years ago

xpcshell test_NetUtil.js fails with SIGSEGV on Android

Categories

(Testing :: General, defect)

x86
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla20

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

Attachments

(1 file)

Android xpcshell tests do not yet run on tbpl, but can be run locally. Running locally, test_NetUtil.js fails with a SIGSEGV.

The crash occurs in the directory provider, at: https://hg.mozilla.org/mozilla-central/file/ae2d36c5dc26/js/xpconnect/shell/xpcshell.cpp#l2116

mGREDir is not set.

I note that the condition for another property checks for a null mGREDir:

https://hg.mozilla.org/mozilla-central/file/ae2d36c5dc26/js/xpconnect/shell/xpcshell.cpp#l2088


This appears to be a regression from bug 810810.
ah, sorry about that. Will post a fix.
Blocks: 810810
This simple null check avoids the crash and allows test_NetUtil.js to pass on Android.

(There may be a bigger issue regarding mGREDir not being set, but I would prefer to handle that if/when I find a test that fails because of that.)
Attachment #685699 - Flags: review?(jmathies)
Comment on attachment 685699 [details] [diff] [review]
guard against null mGREDir

awesome, thanks!
Attachment #685699 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/e042ca3b5c08
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
You need to log in before you can comment on or make changes to this bug.