Make History use slimline Find dialog

VERIFIED FIXED

Status

()

Core
History: Global
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

History currently still uses the old, clumsy Search window, which has limited 
capabilities and a number of UI issues. Should make it use a mechanism similar 
to the bookmark window's new search dialog. 

I plan on just duplicating the code here since the code for the bookmark find 
window is so small (50 lines of XUL, 40 lines of js). 

Patch will also remove "Search Bookmarks/History" items from Mail and Navigator 
Search menus, as these are now separate new mini-dialogs.

Comment 2

17 years ago
So I assume you're removing the combined search window as well?

Comment 3

17 years ago
cool! I like it.
sr=alecf
who wants to r=? blake? timeless? :)

Comment 4

17 years ago
I think but i'm not positive that emacs modleines must be part of the 
first line of a file to be useful:

+<!-- -*- Mode: HTML; indent-tabs-mode: nil; -*- -->

r=timeless if you change that...

Comment 5

17 years ago
+    if ("arguments" in window && window.arguments.length >= 1) {
+      // We have been supplied a resource URI to root the tree on
+      setRoot(window.arguments[0]);
+    }

Can't window.arguments[0] still be null there (aren't all these checks a bitch)?

+<!ENTITY search.for.label               "Find visted documents whose">

I can't wait to look for those visted documents.  (Also, "Find" and "Search 
Results" is a bit inconsistent).

r=blake otherwise

Comment 6

17 years ago
By the way, Ben, this wasn't approved. So you're fired.
Fixed. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Forgot one thing, we need to set the windowtype attribute in the history 
window's init method if we're actually a search window, so that future windows 
can find us using the mediator. 
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 35262 [details] [diff] [review]
Update window type when we're loaded with a search URI parameter
make that ... window.arguments[0] === "" ... 
in the if () check a few lines up in the context. 

Comment 11

17 years ago
[s]r=blake with the window.arguments thing we discussed (whatever you decide on 
that)
Forget my last comment. I was drunk. 
Status: REOPENED → ASSIGNED
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.