[email] Manual setup process can infinitely stack 'setup-manual-config' and 'setup-progress' cards

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: asuth, Assigned: asuth)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
'setup-progress' can push a 'setup-manual-config' card in the failure case where the user hits the manual setup button.
'setup-manual-config' will push a 'setup-progress' card once the user enters their details.

They don't pop each other, so they can stack forever.

In practice this is not a dangerous issue since correctness will be maintained and the user will get tired of re-entering data before we run out of resources.  But really if we already have a manual config card on the stack we should just pop the progress card rather than adding another one.  Or we can otherwise improve the UX flow.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 816036
(Assignee)

Comment 2

6 years ago
I am going to fix this as part of bug 816039.
Assignee: nobody → bugmail
Status: NEW → ASSIGNED
(Assignee)

Comment 3

6 years ago
This is fixed with https://github.com/mozilla-b2g/gaia/pull/7027 from bug 809552.

This was addressed by having us transition back to the card that triggered the account creation attempt.  So when the user tries to create from manual config, they end right back up on the manual config page when the error happens.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 824676

Comment 5

6 years ago
Verified with Unagi, build ID 20130103070201

When the user tries to create an email account from manual configuration page, they end right back up on the manual configuration page when the error happens.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.