Double gmail entry when tapping save too quickly

RESOLVED DUPLICATE of bug 810187

Status

Firefox OS
Gaia::Calendar
RESOLVED DUPLICATE of bug 810187
5 years ago
5 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 685961 [details]
screenshot 1

Adding a Gmail caldav, I entered in my credentials and hit Save.   but i tapped Save twice, while it was still loading.   As a result, i see double Gmail entry.

See screenshots.

Logcat:
11-27 20:38:54.605: E/GeckoConsole(2390): Content JS LOG at app://calendar.gaiamobile.org/js/worker/manager.js:34 in anonymous: [  ] failed to transport err: Error: ical parse error Service.prototype.parseEvent/parser.oncomplete@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:374
11-27 20:38:54.605: E/GeckoConsole(2390): ComponentParser.prototype.process@app://calendar.gaiamobile.org/js/ext/ical.js?time=1354077480743:6215
11-27 20:38:54.605: E/GeckoConsole(2390): Service.prototype.parseEvent@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:385
11-27 20:38:54.605: E/GeckoConsole(2390): Service.prototype._handleCaldavEvent@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:555
11-27 20:38:54.605: E/GeckoConsole(2390): handleResponse@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:631
11-27 20:38:54.605: E/GeckoConsole(2390): emit/<@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1264
11-27 20:38:54.605: E/GeckoConsole(2390): emit@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1263
11-27 20:38:54.605: E/GeckoConsole(2390): Response<.oncomplete@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:2541
11-27 20:38:54.605: E/GeckoConsole(2390): Parser.prototype._fireHandler@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1458
11-27 20:38:54.605: E/GeckoConsole(2390): Parser.pr
11-27 20:38:56.437: E/GeckoConsole(107): Content JS LOG at app://calendar.gaiamobile.org/js/worker/manager.js:34 in anonymous: [  ] failed to transport err: Error: ical parse error Service.prototype.parseEvent/parser.oncomplete@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:374
11-27 20:38:56.437: E/GeckoConsole(107): ComponentParser.prototype.process@app://calendar.gaiamobile.org/js/ext/ical.js?time=1354077480743:6215
11-27 20:38:56.437: E/GeckoConsole(107): Service.prototype.parseEvent@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:385
11-27 20:38:56.437: E/GeckoConsole(107): Service.prototype._handleCaldavEvent@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:555
11-27 20:38:56.437: E/GeckoConsole(107): handleResponse@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:631
11-27 20:38:56.437: E/GeckoConsole(107): emit/<@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1264
11-27 20:38:56.437: E/GeckoConsole(107): emit@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1263
11-27 20:38:56.437: E/GeckoConsole(107): Response<.oncomplete@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:2541
11-27 20:38:56.437: E/GeckoConsole(107): Parser.prototype._fireHandler@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1458
11-27 20:38:56.437: E/GeckoConsole(107): Parser.pr
11-27 20:39:00.151: D/memalloc(2390): /dev/pmem: Unmapping buffer base:0x45985000 size:2723840 offset:2641920
11-27 20:39:00.191: D/memalloc(107): /dev/pmem: Freeing buffer base:0x4af85000 size:81920 offset:2641920 fd:137
11-27 20:39:00.191: D/memalloc(107): /dev/pmem: Freeing buffer base:0x4af99000 size:81920 offset:2723840 fd:141
11-27 20:39:11.412: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 2231, Prog: 31000000, Vers: fc37ad5c, Proc: 00000012
11-27 20:39:11.412: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 2231
11-27 20:39:11.412: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 2231
11-27 20:39:11.412: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 2232, Prog: 31000003, Vers: cf0d42a3, Proc: 00000003
11-27 20:39:11.412: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 2232
11-27 20:39:11.412: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 2232
11-27 20:39:11.522: I/ONCRPC(112): Setup RPC Call for task 4032c420
11-27 20:39:11.522: I/ONCRPC(112): oncrpc_xdr_call_msg_start: Prog: 30000000, Ver: ddc9bd91, Proc: 000000b0
11-27 20:39:11.522: I/ONCRPC(112): xdr_std_msg_send_call: Sent Xid: 3bc, Prog: 30000000, Ver: ddc9bd91, Proc: 000000b0
11-27 20:39:11.522: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 2233, Prog: 31000000, Vers: fc37ad5c, Proc: 00000004
11-27 20:39:11.522: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 2233
11-27 20:39:11.522: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 2233
11-27 20:39:11.522: I/ONCRPC(112): xdr_std_msg_send_call: Received Reply Xid: 3bc, Prog: 30000000, Ver: ddc9bd91, Proc: 000000b0
11-27 20:39:11.522: I/ONCRPC(112): Setup RPC Call for task 4032c420
11-27 20:39:11.522: I/ONCRPC(112): oncrpc_xdr_call_msg_start: Prog: 30000003, Ver: febcbbaf, Proc: 00000058
11-27 20:39:11.522: I/ONCRPC(112): xdr_std_msg_send_call: Sent Xid: 3bd, Prog: 30000003, Ver: febcbbaf, Proc: 00000058
11-27 20:39:11.522: I/ONCRPC(112): xdr_std_msg_send_call: Received Reply Xid: 3bd, Prog: 30000003, Ver: febcbbaf, Proc: 00000058
11-27 20:39:11.522: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 2234, Prog: 31000000, Vers: fc37ad5c, Proc: 0000000f
11-27 20:39:11.522: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 2234
11-27 20:39:11.522: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 2234
11-27 20:39:11.522: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 2235, Prog: 31000003, Vers: cf0d42a3, Proc: 00000001
11-27 20:39:11.522: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 2235
11-27 20:39:11.522: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 2235
11-27 20:39:11.532: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 2236, Prog: 31000003, Vers: cf0d42a3, Proc: 00000003
11-27 20:39:11.532: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 2236
11-27 20:39:11.532: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 2236
11-27 20:39:11.532: I/ONCRPC(112): Setup RPC Call for task 4032c3d8
11-27 20:39:11.532: I/ONCRPC(112): oncrpc_xdr_call_msg_start: Prog: 30000003, Ver: febcbbaf, Proc: 00000069
11-27 20:39:11.532: I/ONCRPC(112): xdr_std_msg_send_call: Sent Xid: 3be, Prog: 30000003, Ver: febcbbaf, Proc: 00000069
11-27 20:39:11.532: I/ONCRPC(112): xdr_std_msg_send_call: Received Reply Xid: 3be, Prog: 30000003, Ver: febcbbaf, Proc: 00000069
11-27 20:39:11.552: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 2237, Prog: 31000003, Vers: cf0d42a3, Proc: 00000004
11-27 20:39:11.552: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 2237
11-27 20:39:11.552: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 2237
11-27 20:39:11.562: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 2238, Prog: 31000003, Vers: cf0d42a3, Proc: 00000001
11-27 20:39:11.562: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 2238
11-27 20:39:11.562: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 2238
11-27 20:39:11.572: I/ONCRPC(112): rpc_handle_rpc_call: for Xid: 2239, Prog: 31000003, Vers: cf0d42a3, Proc: 00000004
11-27 20:39:11.572: I/ONCRPC(112): rpc_handle_rpc_call: Find Status: 0 Xid: 2239
11-27 20:39:11.572: I/ONCRPC(112): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 2239
11-27 20:39:27.217: I/AutoMounter(107): UpdateState: umsAvail:1 umsEnabled:1 mode:0 usbCablePluggedIn:1 tryToShare:0
11-27 20:39:27.217: I/AutoMounter(107): UpdateState: Volume sdcard is Mounted and inserted
11-27 20:39:28.048: E/GeckoConsole(2390): Content JS LOG at app://calendar.gaiamobile.org/js/worker/manager.js:34 in anonymous: [  ] failed to transport err: Error: ical parse error Service.prototype.parseEvent/parser.oncomplete@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:374
11-27 20:39:28.048: E/GeckoConsole(2390): ComponentParser.prototype.process@app://calendar.gaiamobile.org/js/ext/ical.js?time=1354077480743:6215
11-27 20:39:28.048: E/GeckoConsole(2390): Service.prototype.parseEvent@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:385
11-27 20:39:28.048: E/GeckoConsole(2390): Service.prototype._handleCaldavEvent@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:555
11-27 20:39:28.048: E/GeckoConsole(2390): handleResponse@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:631
11-27 20:39:28.048: E/GeckoConsole(2390): emit/<@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1264
11-27 20:39:28.048: E/GeckoConsole(2390): emit@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1263
11-27 20:39:28.048: E/GeckoConsole(2390): Response<.oncomplete@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:2541
11-27 20:39:28.048: E/GeckoConsole(2390): Parser.prototype._fireHandler@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1458
11-27 20:39:28.048: E/GeckoConsole(2390): Parser.pr
11-27 20:39:28.178: E/GeckoConsole(107): Content JS LOG at app://calendar.gaiamobile.org/js/worker/manager.js:34 in anonymous: [  ] failed to transport err: Error: ical parse error Service.prototype.parseEvent/parser.oncomplete@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:374
11-27 20:39:28.178: E/GeckoConsole(107): ComponentParser.prototype.process@app://calendar.gaiamobile.org/js/ext/ical.js?time=1354077480743:6215
11-27 20:39:28.178: E/GeckoConsole(107): Service.prototype.parseEvent@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:385
11-27 20:39:28.178: E/GeckoConsole(107): Service.prototype._handleCaldavEvent@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:555
11-27 20:39:28.178: E/GeckoConsole(107): handleResponse@app://calendar.gaiamobile.org/js/service/caldav.js?time=1354077481596:631
11-27 20:39:28.178: E/GeckoConsole(107): emit/<@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1264
11-27 20:39:28.178: E/GeckoConsole(107): emit@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1263
11-27 20:39:28.178: E/GeckoConsole(107): Response<.oncomplete@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:2541
11-27 20:39:28.178: E/GeckoConsole(107): Parser.prototype._fireHandler@app://calendar.gaiamobile.org/js/ext/caldav.js?time=1354077481228:1458
11-27 20:39:28.178: E/GeckoConsole(107): Parser.pr


Repro:
1) install 11-27-2012 daily unagi build
Version=18.0, BuildID=20121127071547
2) open calendar, and add a Gmail caldav
3) after entering in credentials, tap save twice quickly
4) Verify after calendar is created, the entries are doubled

Expected:'
- single entry, despite double tapping save

Actual:
- double entry shown
(Reporter)

Comment 1

5 years ago
Created attachment 685962 [details]
screenshot 2

Updated

5 years ago
Status: NEW → RESOLVED
blocking-basecamp: ? → ---
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 810187
You need to log in before you can comment on or make changes to this bug.