"Print page" link doesn't work properly

RESOLVED WORKSFORME

Status

()

Core
Layout
P5
normal
RESOLVED WORKSFORME
17 years ago
15 years ago

People

(Reporter: birger.langkjer, Assigned: Marc Attinasi)

Tracking

Trunk
mozilla1.2alpha
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9) Gecko/20010505
BuildID:    2001050515

When I press the link "Print siden", a popop window appears, but there is no
text in it.

Reproducible: Always
Steps to Reproduce:
1. go to http://www.stiften.dk/artikel%3Aaid=19802
2. follow link "Print Siden" (=print page)
3.

Expected Results:  IE behaviour

Comment 1

17 years ago
The "Print siden" link is as follows:

<a href="javascript:void(0);" 
onClick="window.open('/popup:print=19802','print','width=550,height=550,menubar=
no,scrollbars=yes')" class=printgemsend>Print&nbsp;siden</a>

Comment 2

17 years ago
The link is trying to bring up the following complete URL:

             http://www.stiften.dk/popup:print=19802


The link works in IE4.7, but not in NN4.7 or Mozilla, where it comes up
with an advertising banner at the top, but no text underneath.

I believe it may have something to do with resolving the relative
URL given in the anchor. Both NN4.7 and Mozilla can bring up the
absolute URL just fine -

Comment 3

17 years ago
Created attachment 35154 [details]
Reduced HTML testcase (with <base> tag added)

Updated

17 years ago
Assignee: rogerl → neeti
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Networking: HTTP
Ever confirmed: true
OS: Windows 95 → All
QA Contact: pschwartau → tever

Comment 4

17 years ago
Oops, looks like you get a 404 error in any browser on that testcase. 
Oh, well, I tried...

Note: If you try the testcase in NN4.7, you get this error in the
JavaScript Console: 

          JavaScript Error: illegal URL method '/popup:'


Anyway, this is not JavaScript Engine. Reassigning to Networking
for further triage. In case this is a bug with resolving the URL.
(Reporter)

Comment 5

17 years ago
Could it be a missing </table> element? I noticed that is often a problem with 
Netscape.

Comment 6

17 years ago
4.x also behaves the same way. The text in the popup is not showing up. Over to 
layout for further triage.
Assignee: neeti → karnaze
Component: Networking: HTTP → Layout
QA Contact: tever → petersen

Comment 7

17 years ago
not a table specific bug, reassigning to core owner.
Assignee: karnaze → attinasi
OS: All → Windows 3.1
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 8

17 years ago
I don't see any text in IE or Mozilla - just two banner ads.

Moving this out of 0.9.7, and updating the OS (we don't even run on Win3.1)
Status: NEW → ASSIGNED
OS: Windows 3.1 → Windows 95
Priority: -- → P5
Target Milestone: mozilla0.9.7 → mozilla1.2
(Reporter)

Comment 9

17 years ago
The story has likely been moved, because it is too old now. It's the website 
for a newspaper.

Comment 10

15 years ago
worksforme moz2003040708/win98

"Print siden" link in <http://www.stiften.dk/artikel:aid=109599> opens
content-less page in both msie5 and mozilla

"Print siden" link in <http://www.stiften.dk/artikel:aid=109635> opens
page w/ content in both msie5 and Mozilla
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.