Privacy settings drop-down list bug

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Vignesh Giridharan, Unassigned)

Tracking

17 Branch
x86
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

I clicked on the Firefox button on the top left corner to access Options. In Options, I went to the Privacy tab. In the History section, it was set to "Firefox will: Remember History."
I changed that option to "Use custom settings for history" and closed the dialog box.


Actual results:

The setting went back to "Firefox will: Remember History". Every time I change it to "custom" and close it, it keeps going back to "Firefox will: Remember History" if I don't make any changes below in the "custom" option.


Expected results:

I understand that when no "custom" settings are used, it automatically goes back to "Firefox will: Remember History" as that already includes the custom changes I made. But this is bad design. It is confusing. When the drop down is selected to "Use custom settings...", it must remain in that option even if the settings are the same as "Remember History". Otherwise, the user may think that the "custom" options aren't working.
(Reporter)

Updated

5 years ago
Component: Untriaged → Menus
I don't think that this is a bug. It shows that you are using the default values.
Component: Menus → Preferences

Comment 2

5 years ago
Yes, not a bug, if you don't change anything in the custom settings, there is no reason to display the option "Use custom settings for history" the next time you open the menu.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.