On Bluetooth list of devices "Cancel" and "Pair Devices" buttons do not appear.

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Settings
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: mlevin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

1. (Build ID: 20121128071138): Turn on Bluetooth on Unagi phone, turn on Motorola Command One Bluetooth headset. 
2. Search for bluetooth devices using phone.
3. On phone tap the Motorola Command One Bluetooth headset.


Actual results:

Expected Result: 
"Cancel" and "Pair Devices" button options did not appear on the screen of the Unagi phone.


Expected results:

Observed Results:
"Cancel" and "Pair Devices" button options should appear on the screen of the Unagi phone after you tap the bluetooth device on the phone menu. 

NOTE: The Command One Motorola bluetooth headset is a newer headset which has auto pairing and connecting capabilities.
It works for me.
PS. for FirefoxOS, you should use current gecko beta, which is v18.

If first time opening bluetooth pairing, the prompt to ask about if the pin matches would be empty. However, after that, the pin and two buttons would appear.
(Reporter)

Comment 2

5 years ago
Walter Chen if it works for you then please close this bug. I used a more modern bluetooth headset which had auto pairing which does not require a PIN, thus I did not see the "Cancel" and "Pair Devices" buttons. I assume that it just auto paired and connected due to the modernity of my bluetooth headset. This test should be done with a bluetooth device that requires PIN input rather than a modern bluetooth device which bypasses PIN input.
Hi,

I will close as worksforme since I think that the two button didn't show up due that it is paired.

Also, there are few types of bluetooth devices pairing. One is entering pin code, another is looking at both devices to see if devices pin matches, the other is the your phone/device might send the pin for you already. I think for the first two, it should have pair/cancel, but not for the last one.

Thanks for your reporting of bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM

Comment 4

5 years ago
This issue no longer repros.  Verified fixed on Building 20130211070202 Dec 5th Kernel.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.