justified text gets written backwards

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: ferdinandw+bmo, Assigned: mkaply)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)
BuildID:    cvs 20010518

in my self compiled mozilla parts of text that are between <p 
align="justified">and</p> or <div style="text-align:justify">and</div> are 
getting displayed backwards.
at first that happens with the entire block of text, after a while it happens 
on a word for word basis (with a new component.reg, it resets to writing the 
blocks backwards again for a while). the url is a screenshot of the latter 
case. ive been seeing this since bidi landed, but dont see it in nightlies, or 
in my own compile in linux. if i ifdef ibmbidi=1 out in config.mak the problem 
disappears. im building on winMe using msvc6sp5, and dont usually see problems 
that arent in the nightly.

Reproducible: Always
Steps to Reproduce:
1. Compile mozilla on winMe with vc6sp5
2. Go to testcase
3. Notice that the text gets written backwards

Actual Results:  text gets written backwards as a block or on word per word 
basis

Expected Results:  text displayed left to right

will add testcase soon; bug filed with msie because of other bug
(Reporter)

Comment 2

18 years ago
Created attachment 35140 [details]
testcase for this bug
(Reporter)

Comment 3

18 years ago
In my latest build (cvs 2001052710) this problem has disappeared, i still saw
this in a 2001052404 build. Marking this bug worksforme, and will keep an eye
out to see if this bug stays away.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.