Work - richgrid layouts not behaving properly

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: ally, Assigned: mbrubeck)

Tracking

({qawanted, steps-wanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=work [completed-elm])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
sometimes the <richgrid>s that appears on the about:home lays out improperly. instead of being vertical rows they end up as 2 very, very long horizontal rows (instead of a couple of vertical rows in columns of 4-6), wasting a lot of screen space in landscape mode. I am mostly seeing this with recent history, but it may not be limited to that.

I notice that the behavior does not appear when running on desktop in metro mode.

It is unclear if this is a regression. juanb?
(Reporter)

Updated

6 years ago
Blocks: 747789
I've seen this too and if its a regression it predates my joining the project as I /think/ I've seen it sporadically since (my) day 1. 

Related: https://bugzilla.mozilla.org/show_bug.cgi?id=793515
(Reporter)

Comment 2

6 years ago
We talked about how painful this is at the ux meeting yesterday. I imagine we want to add this to our mvp (as much as I don't want to add to the mvp) and make this work a priority in the upcoming iteration.
Whiteboard: [mvp?]
(Assignee)

Comment 3

6 years ago
Agreed.
Keywords: verifyme → qawanted, steps-wanted
OS: Mac OS X → Windows 8 Metro
Hardware: x86 → All
Whiteboard: [mvp?] → [metro-mvp][LOE:2][metro-it3]
(Assignee)

Updated

6 years ago
Depends on: 831410
(Assignee)

Comment 4

6 years ago
Created attachment 702980 [details] [diff] [review]
patch

The main bug happens because StartUI.show is called before ContentAreaObserver.update (which sets the correct width and height styles for the start container) isn't called until the first "resize" event is dispatched.  We need to make sure these are set during startup.

On a related note, the patch makes sure the navigation appbar is visible at startup, to avoid jank when it appears suddenly during the startup process.
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #702980 - Flags: review?(netzen)
Attachment #702980 - Flags: review?(netzen) → review+
(Assignee)

Comment 5

6 years ago
https://hg.mozilla.org/projects/elm/rev/816fa14a7a42
Whiteboard: [metro-mvp][LOE:2][metro-it3] → [metro-mvp][LOE:2][metro-it3][completed-elm]

Updated

6 years ago
Summary: richgrid layouts not behaving properly → Work - richgrid layouts not behaving properly
Whiteboard: [metro-mvp][LOE:2][metro-it3][completed-elm] → feature=work [completed-elm]

Updated

6 years ago
No longer blocks: 747789
(Assignee)

Comment 6

6 years ago
Resolving bugs in the Firefox for Metro product that are fixed on the elm branch.  Sorry for the bugspam.  Search your email for "bugspam-elm" if you want to find and delete all of these messages at once.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.