NPE in Awesomebar which checking for private mode

RESOLVED WONTFIX

Status

()

Firefox for Android
General
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: sriram, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
11-28 15:09:17.546 E/GeckoAppShell( 2124): java.lang.RuntimeException: Unable to start activity ComponentInfo{org.mozilla.fennec/org.mozilla.gecko.AwesomeBar}: java.lang.NullPointerException
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2663)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2679)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at android.app.ActivityThread.access$2300(ActivityThread.java:125)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2033)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at android.os.Handler.dispatchMessage(Handler.java:99)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at android.os.Looper.loop(Looper.java:123)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at java.lang.reflect.Method.invokeNative(Native Method)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at java.lang.reflect.Method.invoke(Method.java:521)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at dalvik.system.NativeStart.main(Native Method)
11-28 15:09:17.546 E/GeckoAppShell( 2124): Caused by: java.lang.NullPointerException
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at org.mozilla.gecko.AwesomeBar.onCreate(AwesomeBar.java:129)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1047)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2627)
11-28 15:09:17.546 E/GeckoAppShell( 2124): 	... 11 more
(Reporter)

Comment 1

5 years ago
Created attachment 686325 [details] [diff] [review]
Patch

This safeguards from NPE on Talos.
Attachment #686325 - Flags: review?(bnicholson)
Comment on attachment 686325 [details] [diff] [review]
Patch

There's other potential problems with opening the AwesomeScreen before a tab exists (like if you try to type a URL and hit go). Normally, tabs will be created immediately at startup before the AwesomeScreen can be opened, so we should figure out how this is happening.

This patch isn't really a fix to this problem, so please file another bug about the AwesomeScreen opening before tabs exist. r+ if you do that and add that bug # as a comment.
Attachment #686325 - Flags: review?(bnicholson) → review+
(Reporter)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/7b516748a65c
Backed out for PB failures
https://hg.mozilla.org/integration/mozilla-inbound/rev/9eb8b4bd265d
(Reporter)

Comment 5

5 years ago
Created attachment 686440 [details] [diff] [review]
Patch

Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=df6e3baaa8db
(I dont know where the last 4 changesets are coming from)
Attachment #686325 - Attachment is obsolete: true
Attachment #686440 - Flags: review?(bnicholson)
(Reporter)

Comment 6

5 years ago
This is no more needed. The null checks -- which caused the tree to burn -- are added in bug 806937.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Attachment #686440 - Flags: review?(bnicholson)
You need to log in before you can comment on or make changes to this bug.