Talos could open AwesomeScreen before tabs exist.

RESOLVED DUPLICATE of bug 816719

Status

()

RESOLVED DUPLICATE of bug 816719
6 years ago
6 years ago

People

(Reporter: sriram, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
If and when that happens, 

E/AndroidRuntime(25935): java.lang.RuntimeException: Unable to start activity ComponentInfo{org.mozilla.fennec_sriramramasubramanian/org.mozilla.gecko.AwesomeBar}: java.lang.NullPointerException
E/AndroidRuntime(25935): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2180)
E/AndroidRuntime(25935): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2230)
E/AndroidRuntime(25935): 	at android.app.ActivityThread.access$600(ActivityThread.java:141)
E/AndroidRuntime(25935): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1234)
E/AndroidRuntime(25935): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime(25935): 	at android.os.Looper.loop(Looper.java:137)
E/AndroidRuntime(25935): 	at android.app.ActivityThread.main(ActivityThread.java:5039)
E/AndroidRuntime(25935): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime(25935): 	at java.lang.reflect.Method.invoke(Method.java:511)
E/AndroidRuntime(25935): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:793)
E/AndroidRuntime(25935): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:560)
E/AndroidRuntime(25935): 	at dalvik.system.NativeStart.main(Native Method)
E/AndroidRuntime(25935): Caused by: java.lang.NullPointerException
E/AndroidRuntime(25935): 	at org.mozilla.gecko.Tabs.getContentResolver(Tabs.java:234)
E/AndroidRuntime(25935): 	at org.mozilla.gecko.AwesomeBar.onCreate(AwesomeBar.java:80)
E/AndroidRuntime(25935): 	at android.app.Activity.performCreate(Activity.java:5104)
E/AndroidRuntime(25935): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1080)
E/AndroidRuntime(25935): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2144)
E/AndroidRuntime(25935): 	... 11 more

would happen. It's better not to open AwesomeBar until then.
The initial about:home tab is created in initializeChrome(), called in initialize(), called in onWindowFocusChanged(). We expect this to happen before the AwesomeScreen can be opened, so it's strange that Talos is hitting this.

Some STR that can cause this outside of Talos (according to sriram) are the following:
1) Open Fennec and go to a URL
2) Force close Fennec
3) Reopen Fennec within 30 seconds (to trigger a session restore)
4) Tap the URL bar immediately

But I don't think talos ever follows the session restore code path, so this seems like a different issue.
See Also: → bug 816314
Turns out Talos is doing a session restore after all.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 816719
You need to log in before you can comment on or make changes to this bug.