Mozilla does not remember 301 responses

VERIFIED DUPLICATE of bug 48202

Status

()

Core
Networking: HTTP
VERIFIED DUPLICATE of bug 48202
17 years ago
17 years ago

People

(Reporter: tenthumbs, Assigned: Darin Fisher)

Tracking

Trunk
mozilla0.9.3
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I don't know if this is HTTP or cache or both. Someone decide.

Consider a fairly common situation. HTML page A has a link to URL B. If
you click on the link, the URL B server returns a 301 response and points
to URL C. Mozilla dutifully goes to the new location and displays the
correct page. If I now go back to page A and click on the same link,
mozilla has no memory of what just happened so it goes to URL B again.  
If the URL B server is slow there can be a noticeable delay in accessing
the real page.

I think mozilla should cache the 301 response so it can avoid repeating
the intermediate step.

Comment 1

17 years ago
cc'ing darin and gordon

Updated

17 years ago
Target Milestone: --- → mozilla0.9.3
(Reporter)

Comment 2

17 years ago
Real world example:  <http://www.w3c.org/>
(Assignee)

Comment 3

17 years ago
this is a regression from my http branch landing.

-> me
Assignee: neeti → darin
(Assignee)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 48202 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

17 years ago
Why is this a dup of 48202? That bug is about form handling and
submission. This one is about caching any 301 response.
(Assignee)

Comment 6

17 years ago
that bug is about fixing our handling of 301 responses... the patch for that
bug will include the fix for this bug as well.

Comment 7

17 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.