[Settings] "Internet Sharing" Wi-Fi hotspot can not enable.

RESOLVED DUPLICATE of bug 815924

Status

Firefox OS
Gaia::Settings
P2
normal
RESOLVED DUPLICATE of bug 815924
5 years ago
5 years ago

People

(Reporter: askeing, Unassigned)

Tracking

({urwanted})

unspecified
ARM
Gonk (Firefox OS)
urwanted

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
After turn on and turn off Wi-Fi hotspot once, then Wi-Fi hotspot can not be enabled.

device: unagi
build: unagi_2012-11-28.zip from https://releases.mozilla.com/b2g/

How to reproduce:
  0. Reset phone.
  1. Open Settings, open Internet sharing.
  2. Enable Wi-Fi hotspot.
  3. Disable Wi-Fi hotspot.
  4. Enable Wi-Fi hotspot again.

Expected results:
  at Step2, Wi-Fi on.
  at Step3, Wi-Fi off.
  at Step4, Wi-Fi on.

Actual results:
  at Step2, Wi-Fi on.
  at Step3, Wi-Fi off.
  at Step4, Wi-Fi on, then it will automatically turn off.
(Reporter)

Updated

5 years ago
Component: General → Gaia::Settings
OS: Linux → All
Hardware: x86_64 → All
Still the same in 2012/12/02 build in https://releases.mozilla.com/b2g/
Need to solve this in order that we can check all the test cases and finished testing for coverage.
blocking-basecamp: --- → ?
blocking-basecamp: ? → +
Priority: -- → P2
Still reproducible in 2012/12/03 build in https://releases.mozilla.com/b2g/
Need to solve this.
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Still reproducible in 2012/12/04 build in https://releases.mozilla.com/b2g/
Need to solve this bug.
Keywords: urwanted
QA Contact: wachen
Created attachment 688620 [details]
logcat

Additional comment: If you open wifi first, you would be able to enable internet sharing(not actually enabled, pc/other phone can't detect it). After few second, it would trigger the internet sharing back to disabled status. And, wifi would be closed, too.
Just to provide more information.

Since I opened wifi before enable internet hotspot sharing, the enabling of internet hotspot sharing is between this 2 blocks of messages.


I/wpa_supplicant(  519): wlan0: Trying to associate with SSID 'Mozilla Guest'
I/wpa_supplicant(  519): wlan0: Associated with 6c:f3:7f:82:86:e1
I/wpa_supplicant(  519): wlan0: CTRL-EVENT-CONNECTED - Connection to 6c:f3:7f:82:86:e1 

... ... ...

I/wpa_supplicant(  519): wlan0: CTRL-EVENT-DISCONNECTED bssid=6c:f3:7f:82:86:e1 reason=3
I/wpa_supplicant(  519): wlan0: CTRL-EVENT-TERMINATING
This bug is INVALID, it's cause by the usability confusion because we did not implement bug 815924. Currently, we turn off wifi hotspot without giving any explanation to the user if mobile data is not enabled.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
More like a duplicate I should say...
Resolution: INVALID → DUPLICATE
Duplicate of bug: 815924
Depends on: 823813
You need to log in before you can comment on or make changes to this bug.