Fix compiler to work with the refactored parser for 1.0

RESOLVED FIXED in 1.0

Status

P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: stas, Assigned: stas)

Tracking

unspecified
x86
Mac OS X
Dependency tree / graph

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Bug 813862 changes the Parser API and introduces a few modifications to the AST.  The compiler needs to be updated accordingly.  Then, we can finally move to using LOL files in the testcases instead of pre-parsed JSON files (bug 810817).
(Assignee)

Comment 1

6 years ago
Created attachment 687010 [details] [diff] [review]
Updated compiler and ctx

This also fixes bug 810817, hence all the changes to the testcases.  I haven't added error emitting;  I'll do it in bug 802845.

The actual patch is bigger because of the indentation change in compiler.js.  The attached patch was produced with "git diff -b" to ignore whitespace changes.
Attachment #687010 - Flags: review?(gandalf)
(Assignee)

Updated

6 years ago
Target Milestone: --- → 1.0
Comment on attachment 687010 [details] [diff] [review]
Updated compiler and ctx

awesome, land this beauty
Attachment #687010 - Flags: review?(gandalf) → review+
(Assignee)

Comment 3

6 years ago
https://github.com/l20n/l20n.js/commit/99363db9d3d553f5e71ed851ad258a6a973287b1
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 816608
You need to log in before you can comment on or make changes to this bug.