Referer: param not sent on new browser windows

VERIFIED DUPLICATE of bug 48902

Status

SeaMonkey
UI Design
--
major
VERIFIED DUPLICATE of bug 48902
17 years ago
14 years ago

People

(Reporter: gaxzero, Assigned: neeti)

Tracking

Trunk
All
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Right click on a link and do "open link in new window" the referer param is not
sent.
http request example:
----------------------------------------------------
GET /examples/servlets/index.html HTTP/1.1
Host: localhost:81
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20010131
Netscape6/6.01
Accept: */*
Accept-Language: en
Accept-Encoding: gzip,deflate,compress,identity
Keep-Alive: 300
Connection: keep-alive
-----------------------------------------

it should send something like: (ie does)
--------------------------
GET /examples/images/return.gif HTTP/1.1
Referer: http://localhost:81/examples/jsp/index.html
Host: localhost:81
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20010131
Netscape6/6.01
...
----------------------------------

some server dont let you look at some files if they were refered by an
anothorized site.  for example, some (porn) sites dont let you look at their
free pictures if you didnt look at their adds... but you cant open them in a new
window.  
in fact, it would be nice if you could specify witch a refere at the command
line so that it works for Shortcuts on desktop. since you could be refered by a app.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 48902 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
VERIFIED:
excellent problem description (I wish this was in the original bug...)

thanks to Keyser for duping.
Status: RESOLVED → VERIFIED

Updated

17 years ago
QA Contact: tever → benc

Comment 3

17 years ago
-> xpapps
Component: Networking: HTTP → XP Apps
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.