application/pdf suddenly stopped working no matter what the Helper Application

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: raines, Assigned: law)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.18pre11-va1.1smp i686; en-US; rv:0.9)
Gecko/20010507
BuildID:    2001050717

Mozilla can no longer handle application/pdf.  It just leaves behind a *.PDF
file in /tmp.  But nothing every happens.  I originally had application/pdf
registered to run 'xpdf %s'.  I tried deleting application/pdf entirely from the
Helper Applications expecting it
to now prompt me to download pdf files.  It still does nothing but leaves behind
a new *.PDF file in /tmp.  I checked plugins but nothing
is registered for application/pdf.  I tried making the helper app for
pdf simply 'xmessage %s' but still nothing.

Reproducible: Always
Steps to Reproduce:
1. Open any link of mime type application/pdf


Actual Results:  Nothing but a *.PDF file left behind in /tmp

Expected Results:  Should have invoked xpdf on the pdf file and deleted it
from /tmp when done

Comment 1

18 years ago
If you're using Acrobat 5, then this is probably a dupe of bug 76892.
this is XP apps.

Don't use 'xpdf %s' -- you need a full path to xpdf and no %s; known bug.
Assignee: rickg → pchen
Component: Viewer App → XP Apps
QA Contact: rickg → sairuh
(Reporter)

Comment 3

18 years ago
Tried using simply /usr/bin/xpdf.  Still silently fails and leaves behind
a *.PDF file in /tmp for each try.  Anyway to get a debugging stream of what
is going on?
bill/shrir, do you see this?
Assignee: pchen → law
QA Contact: sairuh → shrir

Comment 5

18 years ago
works fine for me on today's trunk on linux 0521. Reporter, there is a small 
delay between loading acroread and the actual launching of the file. Acrobat 
reader does not work as a plugin ( known bug). Pls retry.
(Reporter)

Comment 6

18 years ago
Yeah, acroread has always given me problems so I use xpdf.  Much
faster load and I rarely need acroreads extra features.  I never use
the plugin anyway as I hate the "inline" pdf.

Anyway, after a simple quit and restart of mozilla with no preference
changes, it started working again.  A mystery.  I guess you can close
this bug.

Comment 7

18 years ago
*hurries up*....WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 8

18 years ago
:) verif
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.