The Gecko Profiler needs a memory reporter

RESOLVED FIXED in Firefox 54

Status

()

Core
Gecko Profiler
RESOLVED FIXED
5 years ago
3 months ago

People

(Reporter: glandium, Assigned: njn)

Tracking

(Blocks: 3 bugs)

unspecified
mozilla54
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 fixed)

Details

(Whiteboard: [Memshrink:P2])

Attachments

(1 attachment)

I have 1367 tabs open. I did the mistake to click on the tab groups button when i meant to hit the gecko profiler button (oops), and the result is that memory usage went from 1.3GB to 3GB, and about:memory now shows me this:
├──1,708.01 MB (49.49%) ── heap-unclassified
Blocks: 563700
So I /think/ I identified it as being memory coming from SPS. We could definitely do with a memory reporter for SPS.
Component: Panorama → Gecko Profiler
Product: Firefox → Core
Summary: Huge heap-unclassified after opening tab groups page → SPS could use a memory reporter
(Assignee)

Updated

4 years ago
Whiteboard: [Memshrink] → [Memshrink:P2]
Duplicate of this bug: 1305617
Summary: SPS could use a memory reporter → SPS could use a memory reporter / Gecko profiler add-on allocates lots of heap-unclassified memory
Duplicate of this bug: 1194454
Blocks: 1191797
Duplicate of this bug: 922100
Duplicate of this bug: 1007434
Duplicate of this bug: 1112336
Blocks: 1329219
(Assignee)

Comment 7

4 months ago
I'm happy to take this one, though I won't get to it immediately.
Assignee: nobody → n.nethercote
(Assignee)

Updated

3 months ago
Summary: SPS could use a memory reporter / Gecko profiler add-on allocates lots of heap-unclassified memory → The Gecko Profiler needs a memory reporter
(Assignee)

Comment 8

3 months ago
Created attachment 8833852 [details] [diff] [review]
Add a memory reporter for the Gecko Profiler

mstange, please review the profiler parts.

jseward, please review the LUL parts.
Attachment #8833852 - Flags: review?(mstange)
Attachment #8833852 - Flags: review?(jseward)
Comment on attachment 8833852 [details] [diff] [review]
Add a memory reporter for the Gecko Profiler

Looks OK to me.  The potential unsafety that you refer to in the
comments makes me vaguely nervous, but I don't think there's anything
we can do about it.
Attachment #8833852 - Flags: review?(jseward) → review+
(Assignee)

Comment 10

3 months ago
> Looks OK to me.  The potential unsafety that you refer to in the
> comments makes me vaguely nervous, but I don't think there's anything
> we can do about it.

We could convert the std::vector uses to nsTArray or mozilla::Vector. More work, obviously, and I took the lazy path for now...
Comment on attachment 8833852 [details] [diff] [review]
Add a memory reporter for the Gecko Profiler

Review of attachment 8833852 [details] [diff] [review]:
-----------------------------------------------------------------

Seems fairly straightforward. Thanks!
Attachment #8833852 - Flags: review?(mstange) → review+
(Assignee)

Comment 12

3 months ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f97b9305a9132a0f8f2be59f8fab676bebc77bc5
Bug 816598 - Add a memory reporter for the Gecko Profiler. r=mstange,jseward.

Comment 13

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f97b9305a913
Status: NEW → RESOLVED
Last Resolved: 3 months ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.