Closed Bug 816633 Opened 7 years ago Closed 7 years ago

Localized names of applications are not displayed

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-basecamp:+)

RESOLVED FIXED
blocking-basecamp +

People

(Reporter: stas, Assigned: stas)

References

Details

Attachments

(1 file)

I tried a custom build with Italian enabled, and even though we have translations of the apps' names (e.g. https://hg.mozilla.org/gaia-l10n/it/file/eac9a0bade00/apps/settings/manifest.properties) that end up correctly in manifest.webapp, I don't see the translations on the homescreen.

It looks like this caused by build/multilocale.py not stripping the whitespace from "name ".

"it": { 
 "name ": "Impostazioni",
 "description ": "Impostazioni Gaia"
},
Attachment #686710 - Flags: review?(kaze)
Nominating as blocking-basecamp.  We need this to display the names of applications correctly in the localized builds.
blocking-basecamp: --- → ?
Comment on attachment 686710 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6723

I agree this should be considered as bb+.
Attachment #686710 - Flags: review?(kaze) → review+
blocking-basecamp: ? → +
https://github.com/mozilla-b2g/gaia/commit/c4e3ad71b0f8cc42c277792bc7b10e005429c92c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.