[Facebook] Better error messaging needed when you want to import contacts (no data or wifi)

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: marcia, Assigned: jmcf)

Tracking

({l12y, late-l10n, unagi})

unspecified
ARM
Gonk (Firefox OS)
l12y, late-l10n, unagi

Firefox Tracking Flags

(blocking-basecamp:-, b2g18+ fixed)

Details

(Whiteboard: interaction [UX-P3])

Attachments

(6 attachments)

Created attachment 686723 [details]
Screenshot of issue

Seen while running unagi:

Gaia: 1910ebaae9bda968f7da6b0ed42eef906013af30
Gecko: 72dbb825d86b5d003929c3ee1efe1187abd3646e

STR:
1. Do not import any Facebook contacts during first run
2. Go to Contacts and click settings

Expected: I could enable Facebook and add contacts
Actual: The option is completely greyed out - see screenshot

I tried going back in the Developer panel and running through the first run experience, and the option is greyed out there as well.
(Reporter)

Updated

6 years ago
Severity: critical → blocker
Keywords: smoketest
Oddly, after I raised the severity of this, the option is now available again for some reason. One thing that I did do was delete all of my existing contacts.
So I believe this likely happened at a moment when my wifi connection was dropped, but at the time I believed I was still connected or at least had data enabled. I am sure because of the order we run the smoketests that I did not explicitly have wifi turned off at this point. Would be good to have some error messaging if we are not detecting a wifi or data connection in this case.
Severity: blocker → normal
blocking-basecamp: ? → ---
Keywords: regression
Summary: [Facebook] Unable to import any Facebook contacts - option is greyed out → [Facebook] Better error messaging needed when you want to import contacts (no data or wifi)
Confirmed that the FB option enables/disables based on data connection.

Marking b-b? for triage.
blocking-basecamp: --- → ?
(Assignee)

Comment 4

6 years ago
this is not a bug. Please close this.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Assignee: nobody → jmcf
blocking- 

Removing smoketest, we won't block on adding an error/warning message here.
blocking-basecamp: ? → -
Keywords: smoketest
Might be in edge case, but still could be improved IMO - I was connected to wifi, the connection dropped, and I had no idea as a user that I was disconnected. We do offer network connection unavailable messages in other parts of the phone UI such as marketplace, so just pointing this out. 

If you want the bug to be closed, it should be resolved as won't fix.
(Assignee)

Comment 7

6 years ago
Marcia,

When there is a connection error we show a dialog indicating that. What is your suggestion, to make the message more user-friendly?

Comment 8

6 years ago
Hey guys

This bug has been raised somewhere else ages ago, and i have already written copy for it.

trying to find it...
Whiteboard: [UX-P3]

Comment 9

6 years ago
Ok, found it. However sorry, the bug was not raised here in Bugzilla.. but here is what was specified:

If there is no wifi or 3G connection show CTA: "import from facebook". Ensure that the "import from facebook" CTA is disabled to prevent users from dealing with an error message when they try to import from facebook but no connection to wifi/3G is detected. Below the disabled CTA inform and orientate the user as to why it is disabled by outputting the following copy: "Offline. To import Facebook contacts connect to WiFi or data network"
Whiteboard: [UX-P3] → interaction [UX-P3]
(Assignee)

Comment 10

6 years ago
that's already implemented. the FB import is disabled if not network connection is available

Comment 11

6 years ago
(In reply to Jose M. Cantera from comment #10)
> that's already implemented. the FB import is disabled if not network
> connection is available

...but the accompanying orientation message below the disabled CTA of "Offline. To import Facebook contacts connect to WiFi or data network" is still missing, no?
(Assignee)

Comment 12

6 years ago
we have never had any visual specifying that

Comment 13

6 years ago
(In reply to Jose M. Cantera from comment #12)
> we have never had any visual specifying that

ok Jose, i am sorry about that. I know that Vicky was working on the Visual Design for this so i will RFI her to enquire where it is...
Flags: needinfo?(vpg)
Are you talking about error messages? Shouldn't this be an overlay asking you to go and connect? Can you Ayman provide those IA specs. Thanks!
Flags: needinfo?(vpg)
(In reply to Victoria Gerchinhoren from comment #14)
> Are you talking about error messages? Shouldn't this be an overlay asking
> you to go and connect? Can you Ayman provide those IA specs. Thanks!

Hi Victoria,
Ayman is refering to those orientation messages we were talking by e-mail, so when no connection (WI-Fi or 3G) apart of the disabilitation of the "FB Import" button a message should be shown to the user "Offline. To import Facebook contacts connect to WiFi or data network" (Instead of "Not imported yet") 
Can you verify the message fit in the screen?

Comment 16

6 years ago
RFI to Victoria again referencing comment #15 and comment #9
Flags: needinfo?(vpg)
Created attachment 691791 [details]
Shows how the message fits in the screen leayout
Flags: needinfo?(vpg)
Created attachment 691793 [details]
SHows error scenario where by the user needs to click on update password btn
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 19

6 years ago
Created attachment 699662 [details]
Screenshot of No Connection (WiFi/Data) Scenario

Here's a sample on how the "Import Contacts" screen will look like when there's no connection available. As you will see the switch is disabled by changing the opacity of the component (30%), and a message will indicate why the selectors are disabled. This behavior should be consistent both in Import Contacts and FTU.
(Assignee)

Updated

6 years ago
tracking-b2g18: --- → ?
(Assignee)

Comment 20

6 years ago
just only renominating to get attention and the tracking-b2g flag.
Status: NEW → ASSIGNED
blocking-basecamp: - → ?
We would take a patch for this.
blocking-basecamp: ? → -
tracking-b2g18: ? → +
Created attachment 700390 [details]
screenshot of the issue

See Screenshot.  We get some funky wording that doesn't fit the screen well and a URL
(Assignee)

Comment 23

6 years ago
(In reply to Naoki Hirata :nhirata from comment #22)
> Created attachment 700390 [details]
> screenshot of the issue
> 
> See Screenshot.  We get some funky wording that doesn't fit the screen well
> and a URL

Naoki, that's a different problem and a different bug, which is that the window.open error messaging should not be displaying the concerned URL because it can be long and annoy the user. You can open another one for that problem. 

thanks!
(Assignee)

Comment 24

6 years ago
Created attachment 700916 [details]
Pointer to GH PR 7541

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: UX will be worse
Testing completed: Yes
Risk to taking this patch (and alternatives if risky): Low
Attachment #700916 - Flags: review?(igonzaleznicolas)
Attachment #700916 - Flags: approval-gaia-master?(francisco.jordano)
Comment on attachment 700916 [details]
Pointer to GH PR 7541

No risky change, please merge once l10n reviewers approve
Attachment #700916 - Flags: review?(stas)
Attachment #700916 - Flags: approval-gaia-master?(francisco.jordano)
Attachment #700916 - Flags: approval-gaia-master+
(Assignee)

Updated

6 years ago
Keywords: l12y, late-l10n
Attachment #700916 - Flags: review?(igonzaleznicolas) → review+

Comment 26

6 years ago
Comment on attachment 700916 [details]
Pointer to GH PR 7541

Grabbing the review from stas.

https://etherpad.mozilla.org/gaia-copy-guidelines says we should use "Wi-Fi", please update the string to use that instead of Wifi?

With that, r=me.
Attachment #700916 - Flags: review?(stas) → review+
(Assignee)

Comment 27

6 years ago
The suggested literal change has been implemented, thus merging this bug.
(Assignee)

Comment 28

6 years ago
https://github.com/mozilla-b2g/gaia/commit/a71163a4c586919529484c0cfef13bfde8aebe1a
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Verified fixed in 2013-02-05-07-02-01 pvt nightly b2g18 build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.