[facebook] search during the import of Facebook slows to a crawl when there's over 500 contacts

RESOLVED FIXED in B2G C3 (12dec-1jan)

Status

P3
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: nhirata, Assigned: jmcf)

Tracking

({perf})

unspecified
B2G C3 (12dec-1jan)
x86
Mac OS X

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

189 bytes, text/html
arcturus
: review+
basiclines
: review+
Details
## Environment :
Unagi phone, build 2012/11/29
  
## Repro :
1. go to contacts -> settings -> import from facebook
2. log into facebook
3. type in facebook account w/ at least 500 contacts
4. type in some random characters  

## Expected :
1. no perf issues, should be able to do your search

## Actual :
1. takes more than a minute to type more than 1 character

## Note :

Updated

6 years ago
Component: Gaia → Gaia::Contacts
QA Contact: isabelrios
(Assignee)

Updated

6 years ago
blocking-basecamp: --- → ?
(Assignee)

Comment 1

6 years ago
nominating this as this also affects search performance of Contacts app as the search code is shared. I was discussing today with crdlc some ideas on how to improve the performance of search, thus I'm going to assign this one.
Assignee: nobody → jmcf
Status: NEW → ASSIGNED
BB+, P2 as its quite easy to have over 500 contacts from Facebook.
blocking-basecamp: ? → +
Priority: -- → P3
(Assignee)

Comment 3

6 years ago
Created attachment 688763 [details]
Pointer to GH PR
Attachment #688763 - Flags: review?(igonzaleznicolas)
Attachment #688763 - Flags: review?(francisco.jordano)

Comment 4

6 years ago
Mass Modify: All un-milestoned, unresolved blocking-basecamp+ bugs are being moved into the C3 milestone. Note that the target milestone does not mean that these bugs can't be resolved prior to 12/10, rather C2 bugs should be prioritized ahead of C3 bugs.
Target Milestone: --- → B2G C3 (12dec-1jan)

Updated

6 years ago
Duplicate of this bug: 796392
Attachment #688763 - Flags: review?(francisco.jordano) → review+
(Assignee)

Comment 6

6 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=816742
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Attachment #688763 - Flags: review?(igonzaleznicolas) → review+
You need to log in before you can comment on or make changes to this bug.