bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Add dummy POD for unPODded methods

RESOLVED FIXED in Bugzilla 5.0

Status

()

Bugzilla
Testing Suite
--
enhancement
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Wurblzap, Assigned: Wurblzap)

Tracking

4.3.2
Bugzilla 5.0
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

33.78 KB, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Assignee)

Description

6 years ago
Created attachment 686825 [details] [diff] [review]
Patch

Bug 784072 needs POD for all methods in order to be useful. The attached patch adds dummy POD for currently unPODded methods.

The dummy POD is entirely empty for each method, so Pod::Coverage introduced by bug 784072 should not use the nonwhitespace option.
Attachment #686825 - Flags: review?(LpSolit)

Comment 1

6 years ago
Comment on attachment 686825 [details] [diff] [review]
Patch

With your patch, t/011pod.t throws a lot of:

*** WARNING: =head2 without preceding higher level at line 4300 in file Bugzilla/Bug.pm

Make sure to run |runtests.pl -v 11| to see these warnings.
Attachment #686825 - Flags: review?(LpSolit) → review-
(Assignee)

Comment 2

6 years ago
What, you deny review because of this?? This is dummy POD generated by a script, so that your other patch can get in. Generated POD from this is just fine. What's the problem here? We need tidy-up bugs for PODding anyway, so this can be cleaned up there, don't you think?

Comment 3

6 years ago
(In reply to Marc Schumann [:Wurblzap] from comment #2)
> What, you deny review because of this?? This is dummy POD generated by a
> script, so that your other patch can get in. Generated POD from this is just
> fine. What's the problem here? We need tidy-up bugs for PODding anyway, so
> this can be cleaned up there, don't you think?

The problem is that these warnings make Tinderbox to turn orange. So this doesn't help. Your patch doesn't make my code to throw these warnings. It's the existing code in 011pod.t which complains.
(Assignee)

Comment 4

6 years ago
Okay, does s/head2/head1/g help?

Comment 5

6 years ago
(In reply to Marc Schumann [:Wurblzap] from comment #4)
> Okay, does s/head2/head1/g help?

Yes, all warnings are now gone.
(Assignee)

Comment 6

6 years ago
All right, so please r+ this and I'll do the replacement on check-in.

Comment 7

6 years ago
Created attachment 687077 [details] [diff] [review]
patch, v2

I replaced all head2 by head1 in your patch to confirm this was working fine. So here is the updated patch, so that you don't need to bother doing it yourself. :) r=LpSolit
Attachment #686825 - Attachment is obsolete: true
Attachment #687077 - Flags: review+

Updated

6 years ago
Flags: approval+
(Assignee)

Comment 8

6 years ago
Thanks. Had it done already, while waiting for your answer ;)

Committing to: bzr+ssh://wurblzap%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla.pm
modified Bugzilla/Attachment.pm
modified Bugzilla/Bug.pm
modified Bugzilla/BugMail.pm
modified Bugzilla/BugUrl.pm
modified Bugzilla/CGI.pm
modified Bugzilla/Chart.pm
modified Bugzilla/Classification.pm
modified Bugzilla/Comment.pm
modified Bugzilla/Component.pm
modified Bugzilla/Config.pm
modified Bugzilla/Constants.pm
modified Bugzilla/DB.pm
modified Bugzilla/Extension.pm
modified Bugzilla/Field.pm
modified Bugzilla/Flag.pm
modified Bugzilla/FlagType.pm
modified Bugzilla/Group.pm
modified Bugzilla/Install.pm
modified Bugzilla/JobQueue.pm
modified Bugzilla/Keyword.pm
modified Bugzilla/Mailer.pm
modified Bugzilla/Migrate.pm
modified Bugzilla/Milestone.pm
modified Bugzilla/Object.pm
modified Bugzilla/Product.pm
modified Bugzilla/RNG.pm
modified Bugzilla/Report.pm
modified Bugzilla/Search.pm
modified Bugzilla/Series.pm
modified Bugzilla/Status.pm
modified Bugzilla/Template.pm
modified Bugzilla/Token.pm
modified Bugzilla/User.pm
modified Bugzilla/Util.pm
modified Bugzilla/Version.pm
modified Bugzilla/WebService.pm
modified Bugzilla/Attachment/PatchReader.pm
modified Bugzilla/Auth/Verify.pm
modified Bugzilla/Config/Common.pm
modified Bugzilla/DB/Mysql.pm
modified Bugzilla/DB/Pg.pm
modified Bugzilla/DB/Schema.pm
modified Bugzilla/DB/Sqlite.pm
modified Bugzilla/DB/Schema/Mysql.pm
modified Bugzilla/DB/Schema/Oracle.pm
modified Bugzilla/DB/Schema/Pg.pm
modified Bugzilla/DB/Schema/Sqlite.pm
modified Bugzilla/Field/Choice.pm
modified Bugzilla/Field/ChoiceInterface.pm
modified Bugzilla/Install/CPAN.pm
modified Bugzilla/Install/Filesystem.pm
modified Bugzilla/Install/Requirements.pm
modified Bugzilla/Install/Util.pm
modified Bugzilla/Job/Mailer.pm
modified Bugzilla/JobQueue/Runner.pm
modified Bugzilla/Migrate/Gnats.pm
modified Bugzilla/Search/Clause.pm
modified Bugzilla/Search/ClauseGroup.pm
modified Bugzilla/Search/Condition.pm
modified Bugzilla/Search/Quicksearch.pm
modified Bugzilla/Search/Recent.pm
modified Bugzilla/Search/Saved.pm
modified Bugzilla/Send/Sendmail.pm
modified Bugzilla/Template/Context.pm
modified Bugzilla/WebService/Bug.pm
modified Bugzilla/WebService/Constants.pm
modified Bugzilla/WebService/Product.pm
modified Bugzilla/WebService/Server.pm
modified Bugzilla/WebService/Util.pm
modified Bugzilla/WebService/Server/JSONRPC.pm
modified Bugzilla/WebService/Server/XMLRPC.pm
modified Bugzilla/Whine/Query.pm
modified Bugzilla/Whine/Schedule.pm
Committed revision 8494.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.