[Message] Strange behaviours in deleting message

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: wachen, Assigned: borjasalguero)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
*Phone: Unagi
2012-11-29
https://releases.mozilla.com/b2g/

*How to reproduce:
  1. send or receive a message
  2. view the message
  3. click to edit the messages
  4. choose some to delete

*Expected Result: 
    some of them got chosen and able to show a proper message before deleting them.

*Actual Result:
    You can't select "some" messages, you can only select or deselect all messages. Before deleting, the warning message shows a strange message of "?Delete selected messages" instead of "Delete selected messages?"
The checkbox in message view (not thread view) edit mode could not be selected now, so we could only choose select all to select the messages to delete. It should be a blocker.
Assignee: nobody → schung
blocking-basecamp: --- → ?
Update: In the latest gaia Moz-central build (f448522a0f1481c9118519f94dfbc6e29f2a0042), no matter which message I tap, only the first message in the thread would be select/deselect.
(Reporter)

Comment 3

6 years ago
Please notice that v18(current beta) is the targeted FirefoxOS v1. current moz-central is v20.
As for my result, using 2012-12-11 build in https://releases.mozilla.com/b2g/. It's still the same, none of the message can be selected.
(Reporter)

Updated

6 years ago
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Thank for the notification. Maybe sms devs made some changes recently but it still got some problems. More precisely to the m-c build, selecting the 'received' messages could reproduce this issue(sent messages could be select/deselect correctly).
Triage: This sounds like a broken feature and a regression.
blocking-basecamp: ? → +
Component: Gaia → Gaia::SMS
Keywords: regression
Priority: -- → P2
QA Contact: mbarone976
(Assignee)

Updated

6 years ago
Assignee: schung → fbsc
(Assignee)

Comment 6

6 years ago
We had some issues with BB of List there, but was fixed yesterday. Im gonna try again and I will come back with more feedback
(Assignee)

Comment 7

6 years ago
Confirmed. After the latest modifications in BB List in SMS is working properly with:
Gaia commit: b812944127dec5bbb6f66a8a1821657577021bff

Im gonna mark it as 'resolved'. If you find that it persist, please reopen!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 8

6 years ago
Tested with the Unagi build
- Gecko: eea4b35
- Gaia: 460ba0c

Still able to reproduce the problem. Is not possible to delete individual messages. The user can use the options "Select All" and "Deselect All"
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

6 years ago
This is due to the change is not in your build yet. Tomorrow you will have it!
(Assignee)

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

6 years ago
fixed verified in http://releases.mozilla.com/b2g/ 20121212 build

However this is causing another bug. I will be filing another bug later
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.