taskbar tab preview list broken if multiple tabs opened at same time via "Open All in Tabs" in Bookmarks

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
3 years ago

People

(Reporter: James, Unassigned)

Tracking

18 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20121128060531

Steps to reproduce:

1. Went up to the Bookmarks Menu.
2. Opened it and went to a folder that has 21 favorites in it.
3. I then selected the "Open All in Tabs" option for that folder.


Actual results:

All the tabs were opened properly, however, when I hover over the Firefox icon in my taskbar, only the preview for the active tab showed up.


Expected results:

Instead of a preview for the active tab (and just that tab) showing up, I should have gotten the list of active tabs that shows up after 16+ tabs are opened in Firefox.

If I manually open up 16+ tabs, the list properly shows up allowing me to select the tab I want.

This seems to me to be a regression possibly since I remember this working just fine in Firefox 17.
Keywords: regressionwindow-wanted
Summary: tab list broken if multiple tabs opened at same time via "Open All in Tabs" in Bookmarks → taskbar tab preview list broken if multiple tabs opened at same time via "Open All in Tabs" in Bookmarks
(Reporter)

Comment 1

6 years ago
Little more info about this after some more testing.  It seems this bug happens when there are 21 or more tabs open at the same time.

Also, it's doesn't seem to be isolated to just the "Open All in Tabs" feature in the Bookmarks like I thought originally.  I tested this by just opening FF and this continued hitting "Ctrl+T" to open new blank tabs.  At 16, the tab list showed up, but once I got to 21, the tab list disappeared and only the preview of the active tab showed up hovering over the Firefox icon in the taskbar.
(Reporter)

Comment 2

6 years ago
And I just downgraded to Firefox 17 for a moment and it was happening there.  So, there might not be a regression here like I thought at first...

I just thought that the taskbar tab preview list was able to show more than 20 on the list (non-preview mode) before this.  And I now see that the "browser.taskbar.previews.max" in about:config is set at 20...

Dang, I feel like a complete idiot here now. :facepalm:  If there is a way to mark this as invalid, please do so as there is no bug here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.