"help" command in Firefox console for localized (NL) build opens 404 Not Found page

VERIFIED WORKSFORME

Status

Mozilla Localizations
nl / Dutch
VERIFIED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Johan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

I opened the Firefox developer console (Ctrl + Shift +K) and typed "help" (without quotes). Then I pressed Enter.


Actual results:

It opened the following URL: https://developer.mozilla.org/nl/AppLinks/WebConsoleHelp?locale=nl

The URL displays a 404 Not Found page.


Expected results:

It should have shown (localized) documentation for the Firefox console.
This page is not yet translated to dutch, see https://developer.mozilla.org/nl/docs/Tools/Web_Console/Helpers?redirectlocale=en-US&redirectslug=Tools%2FWeb_Console%2FWebConsoleHelp

Let's find out why there is no fall back to the en-US site when a localization is not available, Pike?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Johan, thanks for reporting.

Turns out this url doesn't get referenced in nightly no more, but now references https://developer.mozilla.org/docs/Tools/Web_Console/Helpers.

Can you confirm in a Dutch nightly?

Resolving WORKSFORME, 'cause it does on the German nightly, which works with the untranslated page and fallback.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/19.0 Firefox/19.0 with nl langpack

confirm https://developer.mozilla.org/docs/Tools/Web_Console/Helpers
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.