Closed Bug 817049 Opened 7 years ago Closed 2 years ago

Saving image files with certain URLs via drag/drop results in invisible files (e.g. ".jpg")

Categories

(Firefox :: File Handling, defect)

19 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 643096

People

(Reporter: nfagerlund, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:19.0) Gecko/20121129 Firefox/19.0
Build ID: 20121129042015

Steps to reproduce:

Certain image files (for example, viewed attachments from Gmail) have URLs that lack a "filename" component -- they go directly from a slash to a "?q=etc" argument string. (Example URL: https://mail-attachment.googleusercontent.com/attachment/u/0/?ui=2&ik=a004ce9f3a&view=att&th=13b527a442fe1424&attid=0.1&disp=inline&safe=1&zw&saduie=AG9B_P9F0VoYKxtrzCaSQAjqihNs&sadet=1354300347067&sads=utYBuGNSCcYmE809yYpMMBrUDfg)

I attempted to save one of these files to disk via drag-and-drop.


Actual results:

The file was saved with a blank filename and only an extension, e.g. ".jpg" or ".png". On unixy platforms like OS X, these count as invisible files, and it looked like the save operation failed. Dragging it a second time resulted in a second, visible file with a filename like "-1.jpg". The original file continued to lurk invisibly until I checked for it with ls -a.

This doesn't 


Expected results:

It should have behaved similarly to hitting cmd-S while viewing the image, which comes up with a default filename from somewhere instead of saving it with an invisible name. (Not sure where the default comes from. Exif data? Mars? It wasn't part of the URL.)
Component: Untriaged → File Handling
I was able to reproduce the issue on the latest Nightly, while viewing an attachement using Gmail. The attachement was a .jpg file.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20121210 Firefox/20.0
Build ID: 20121210030747
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 643096
You need to log in before you can comment on or make changes to this bug.