Too much space above tab bar when TB window is restored to window-size (original size, non-maximized)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: ovaalst, Unassigned)

Tracking

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 687185 [details]
Windowed vs Full screen.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

I noticed too much space above the Tab in TB when the TB-windows is made smaller than full screen.



Expected results:

I expected a similar view with the smaller view than the full screen-window. I attached 2 screenshots for comparison: above is in Windowed view, below is the Full screen version.

I also noticed that in Windowed-view the personas-theme is displayed to all the way of the top of the window; at the same time there is an Aero opaque outline on the other 3 sides of the window: left, right an bottom.
It maybe right, but it looks a bit weird to me.
(In reply to Coyote from comment #0)
> Created attachment 687185 [details]
> Windowed vs Full screen.png
> I noticed too much space above the Tab in TB when the TB-windows is made
> smaller than full screen.

I think that extra top margin when TB window is "restored" (non-maximized, original size) has been added by design to allow dragging the window around, which would be difficult otherwise if you have many tabs open.

Arguably, it could be a few pixels less high, but if we make it too narrow, we'll get complaints that users might be unable to drag the window when they miss the margin.
(Reporter)

Comment 2

6 years ago
I didn't think about that, but that is very plausible of course. 

Same could be said of the Personas image, extended all the way to the top op the Window, "surpassing" the opaque aero border, while on the other 3 sides of the window the aero outline is still visible. Maybe a different "bug", but before posting a new bug about it, it's maybe better to hear what the opinion is.
(In reply to Coyote from comment #2)
> I didn't think about that, but that is very plausible of course. 

Coyote, thanks 4 quick & cooperative reply :)

> Same could be said of the Personas image, extended all the way to the top op
> the Window, "surpassing" the opaque aero border, while on the other 3 sides
> of the window the aero outline is still visible. Maybe a different "bug",
> but before posting a new bug about it, it's maybe better to hear what the
> opinion is.

That sounds like a bug to me (albeit trivial), we probalby should not cover the aero borders. Can you attach a screenshot of that problem?
I've seen some similar complaints recently, like bug 819707. I think we can use that bug to cover that problem.

So I think we can close this wfm, per reporter's comment 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Summary: Too much space above tab in Windowed screen → Too much space above tab bar when TB window is restored to window-size (original size, non-maximized)
(Reporter)

Comment 4

6 years ago
I have a screenshot about the Personas "issue": http://s11.postimage.org/c77i9x6df/Personas_image_surpassing_Aero_outline_border_on.png

I tried both "issues" with Firefox and the behaviour there was exactly the same.

* The extra space also appears when the Window is made smaller.
* Personas on Firefox also results in a non visible Aero outline on top. I think it is done to have more space to show the personas.

So I conclude that this choice was made by design. The little difference is that the menu button on FF is still top-left.

Sorry for this confusing bug, it just looked a little weird to me :-)
You need to log in before you can comment on or make changes to this bug.