Inline webm video cannot be replayed in firefox.

RESOLVED DUPLICATE of bug 795784

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 795784
5 years ago
5 years ago

People

(Reporter: djvj, Unassigned)

Tracking

({regression, testcase})

15 Branch
x86
All
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 687242 [details]
Test Case.

This was brought to my attention by Fernando Perez of the iPython Notebook project, and he helpfully provided me with a good testcase of the issue.

When using embedded base-64 content for webm video (i.e. the content is specified directly as an attribute of the video tag, encoded in base-64), webm videos seem to only be playable once, and don't allow restarting.

Testcase page is attached.  The first video on the page is an OGG file, and works fine.  The second video is a WEBM file, and cannot be played more than once without reloading the page.
WFM against Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1 ID:20120713134347

Fails in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.11) Gecko/20100101 Firefox/10.0.11 ID:20121115102332
and
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121202 Firefox/20.0 ID:20121202030723
Keywords: regression, regressionwindow-wanted, testcase
OS: Mac OS X → All
(In reply to XtC4UaLL [:xtc4uall] from comment #1)
> Fails in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.11) Gecko/20100101
> Firefox/10.0.11 ID:20121115102332

Arrg, rather should have been
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0 ID:20121128204232

Comment 3

5 years ago
Regression window(cached m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b72c41ab1bd3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120518095652
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/1e18c991b40c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120518103652
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b72c41ab1bd3&tochange=1e18c991b40c

In local build:
Last Good: 5232403e7b8f
First Bad: 1e18c991b40c

Triggered by:
1e18c991b40c	Paul Adenot — Bug 756372 - Change |seeking| to prevent seeking in WebM livestream. r=kinetik
Blocks: 756372
Keywords: regressionwindow-wanted

Updated

5 years ago
Version: 17 Branch → 15 Branch

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 795784
You need to log in before you can comment on or make changes to this bug.