Add an option to disable overview zoom level

RESOLVED DUPLICATE of bug 666600

Status

()

Firefox for Android
Toolbar
RESOLVED DUPLICATE of bug 666600
6 years ago
6 years ago

People

(Reporter: Frederik Niedernolte, Unassigned)

Tracking

18 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Try to find an option to disable the default zoom level overview


Actual results:

Nothing found


Expected results:

There should be an option to disable the overview mode and zoom / scale / center the content properly for mobile phones.
To see a full desktop site which is not mobile optimised with a 4.x inch screen isn't useful and text in forums like XDA looks strange (sometimes big, sometimes small).
Please add an option like the stock browser with a custom zoom level.
Already present. Menu button/3 dot button -> settings -> text size -> press the small 'A' till the text size no longer changes -> press set.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

6 years ago
Created attachment 687681 [details]
Firefox1
(Reporter)

Comment 3

6 years ago
Created attachment 687682 [details]
Firefox2
(Reporter)

Comment 4

6 years ago
Created attachment 687684 [details]
Stock1
(Reporter)

Comment 5

6 years ago
Created attachment 687685 [details]
Stock2
(Reporter)

Comment 6

6 years ago
I think you misunderstood me. 
Look at the screenshot from my phone and compare Firefox with stock browser. 
I don't talk about the zoom level but about overview mode on/off. 
Do you understand what the difference is? 
Currently it is not possible with Firefox for Android which is okay for Tablets but not handy and ugly for phones.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
This might happen because of the font inflation. Set the text size to tiny and recheck those pages. It should be displayed the same as for the stock browser
(Reporter)

Comment 8

6 years ago
Created attachment 687697 [details]
FirefoxTiny
(Reporter)

Comment 9

6 years ago
Okay, "tiny" solves a part of the problem (even if the option doesn't sound like that) but as you can see on the screenshot the page is still in "overview" mode. 
In the stock browser you can read everything without zooming and panning. 
In Firefox the page is rendered too wide and you have to scroll vertically AND horizontally. The text should be always as wide as the screen if there would be an option for that like in the stock browser.
Please select PNG image when you add a png as attachment. I cannot see any of the attached images :( it seems that were attached as plain text
(Reporter)

Updated

6 years ago
Attachment #687681 - Attachment mime type: text/plain → image/png
(Reporter)

Updated

6 years ago
Attachment #687682 - Attachment mime type: text/plain → image/png
(Reporter)

Updated

6 years ago
Attachment #687684 - Attachment mime type: text/plain → image/png
(Reporter)

Updated

6 years ago
Attachment #687685 - Attachment mime type: text/plain → image/png
(Reporter)

Updated

6 years ago
Attachment #687697 - Attachment mime type: text/plain → image/png
(Reporter)

Comment 11

6 years ago
Sorry, should be fixed now. 
Compare especially the last two screnshots
Indeed, there is a difference between them. However, the webpage displayed with the Tiny text setting looks almost like it does on desktop.
(Reporter)

Comment 13

6 years ago
That is true and I said already that it is okay for Tablets but not for Smartphones. 
If there would be an option like in the stock browser to disable overview mode (including text reflow) everyone could be happy.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 666000
Whoops, wrong bug number.
Duplicate of bug: 666600
You need to log in before you can comment on or make changes to this bug.