Last Comment Bug 817329 - "this addon could not be installed because it appears to be corrupt" is quite invisible
: "this addon could not be installed because it appears to be corrupt" is quite...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: Thunderbird 22.0
Assigned To: Richard Marti (:Paenglab)
:
Mentors:
: 847295 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-01 13:33 PST by Vincent (caméléon)
Modified: 2013-03-26 07:42 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
funambol-mozilla-sync-client-win32-tb17+dev17.xpi (5.98 KB, application/x-xpinstall)
2012-12-01 13:33 PST, Vincent (caméléon)
no flags Details
screenshot of the issue (130.66 KB, image/png)
2012-12-01 13:33 PST, Vincent (caméléon)
no flags Details
patch (13.73 KB, patch)
2013-01-26 02:59 PST, Richard Marti (:Paenglab)
no flags Details | Diff | Splinter Review
patch in action (20.92 KB, image/png)
2013-01-26 03:01 PST, Richard Marti (:Paenglab)
no flags Details
patch (13.76 KB, patch)
2013-01-26 14:57 PST, Richard Marti (:Paenglab)
bwinton: ui‑review+
Details | Diff | Splinter Review
patch v2 (14.43 KB, patch)
2013-02-17 13:11 PST, Richard Marti (:Paenglab)
richard.marti: ui‑review+
Details | Diff | Splinter Review
The actual background color (9.09 KB, image/png)
2013-02-17 13:11 PST, Richard Marti (:Paenglab)
no flags Details
patch v2 unbitrotted (14.45 KB, patch)
2013-02-28 13:13 PST, Richard Marti (:Paenglab)
mconley: review+
richard.marti: ui‑review+
Details | Diff | Splinter Review

Description Vincent (caméléon) 2012-12-01 13:33:11 PST
Created attachment 687441 [details]
funambol-mozilla-sync-client-win32-tb17+dev17.xpi

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

1/ Try to install the add-on attached to this bug (which seems to be a corrupt funambol add-on for TB17 from https://maurus.net/resources/funambol/tb17-dev17/)



Actual results:

Nothing. After looking at it a little bit more, I have seen the error message at the top of the TB windows (attached to the bug report too)


Expected results:

Text color should be in black in order to improve its readability (any other suggestion would be accepted except this white text on a clear background).
Comment 1 Vincent (caméléon) 2012-12-01 13:33:54 PST
Created attachment 687442 [details]
screenshot of the issue
Comment 2 Wayne Mery (:wsmwk, NI for questions) 2013-01-23 11:35:58 PST
Is this a theme issue?
Or addon manager?
Comment 3 Richard Marti (:Paenglab) 2013-01-23 12:09:40 PST
Because Firefox uses now the arrow-popups it's a theme issue.

I'll take it.
Comment 4 Richard Marti (:Paenglab) 2013-01-26 02:59:41 PST
Created attachment 706774 [details] [diff] [review]
patch

I removed the special styling for value="addon-install-failed" and let the original styling of notification.css.

I've added inverted close icons to have a better contrast.
Comment 5 Richard Marti (:Paenglab) 2013-01-26 03:01:02 PST
Created attachment 706775 [details]
patch in action

Screenshot for easier ui-r
Comment 6 Vincent (caméléon) 2013-01-26 12:06:56 PST
looks great, thanks!
Comment 7 Richard Marti (:Paenglab) 2013-01-26 14:57:41 PST
Created attachment 706813 [details] [diff] [review]
patch

Sorry, forgot one change.
Comment 8 Blake Winton (:bwinton) (:☕️) 2013-02-17 12:03:35 PST
Comment on attachment 706813 [details] [diff] [review]
patch


>+++ b/mail/themes/gnomestripe/mail/messenger.css
>@@ -393,20 +393,33 @@
> notification[value="addon-install-blocked"],
>-notification[value="addon-install-failed"],
> notification[value="addon-install-complete"] {
>   background-image: url("chrome://mozapps/skin/extensions/stripes-info-negative.png"),
>                     linear-gradient(rgba(255, 255, 255, 0), rgba(255, 255, 255, 0.5));
>   background-repeat: repeat-x;
> }

The red seems a little bright.  I suggest we add something like:

notification[value="addon-install-failed"] {
  background-image: url("chrome://mozapps/skin/extensions/stripes-error.png"),
                    linear-gradient(rgba(255, 0, 0, 0), rgba(255, 0, 0, 0.5));
  background-repeat: repeat-x;
}

instead.  (Uh, feel free to play around with the colours there…)

Aside from that, ui-r=me!

Thanks,
Blake.
Comment 9 Richard Marti (:Paenglab) 2013-02-17 13:11:09 PST
Created attachment 714962 [details] [diff] [review]
patch v2

The red background color was the original from notification.css. This patch lightens the red a little bit.
Comment 10 Richard Marti (:Paenglab) 2013-02-17 13:11:48 PST
Created attachment 714963 [details]
The actual background color
Comment 11 Richard Marti (:Paenglab) 2013-02-28 13:13:55 PST
Created attachment 719654 [details] [diff] [review]
patch v2 unbitrotted

Patch was bitrotted by HiDPI check-in.
Comment 12 Richard Marti (:Paenglab) 2013-03-04 00:30:53 PST
*** Bug 847295 has been marked as a duplicate of this bug. ***
Comment 13 Mike Conley (:mconley) - (Needinfo me!) 2013-03-23 11:29:04 PDT
Comment on attachment 719654 [details] [diff] [review]
patch v2 unbitrotted

Review of attachment 719654 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me! Thanks Paenglab!
Comment 14 Mark Banner (:standard8) (afk until 26th July) 2013-03-26 07:42:51 PDT
https://hg.mozilla.org/comm-central/rev/20c2fd173fa9

Note You need to log in before you can comment on or make changes to this bug.