Last Comment Bug 817502 - Permanent orange: TEST-UNEXPECTED-FAIL | multiple-identities/test-display-names.js | test_no_header_name_in_abook_no_pdn (got 'null' but expected 'My Buddy')
: Permanent orange: TEST-UNEXPECTED-FAIL | multiple-identities/test-display-nam...
Status: RESOLVED FIXED
: intermittent-failure, regression
Product: Thunderbird
Classification: Client Software
Component: Address Book (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 20.0
Assigned To: :aceman
:
Mentors:
Depends on:
Blocks: 814195 819798
  Show dependency treegraph
 
Reported: 2012-12-03 00:33 PST by Mark Banner (:standard8)
Modified: 2012-12-10 03:19 PST (History)
8 users (show)
standard8: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (3.83 KB, patch)
2012-12-08 12:40 PST, :aceman
no flags Details | Diff | Review
patch v2 (3.44 KB, patch)
2012-12-08 13:48 PST, :aceman
no flags Details | Diff | Review
patch v3 (3.68 KB, patch)
2012-12-09 05:37 PST, :aceman
squibblyflabbetydoo: review+
Details | Diff | Review

Description Mark Banner (:standard8) 2012-12-03 00:33:24 PST
This popped up over the weekend:

SUMMARY-UNEXPECTED-FAIL | test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
  EXCEPTION: got 'null' but expected 'My Buddy'
    at: test-display-names.js line 99
       help_test_display_name test-display-names.js 99
       test_no_header_name_in_abook_no_pdn test-display-names.js 159
       Runner.prototype.wrapper frame.js 582
       Runner.prototype._runTestModule frame.js 652
       Runner.prototype.runTestModule frame.js 698
       Runner.prototype.runTestDirectory frame.js 522
       runTestDirectory frame.js 704
       Bridge.prototype._execFunction server.js 179
       Bridge.prototype.execFunction server.js 183

https://tbpl.mozilla.org/php/getParsedLog.php?id=17541618&tree=Thunderbird-Trunk#error2

Regression range: 

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0e6c4d6047db&tochange=ecdf0e332f17

I've currently got a bisect running to investigate further as the failure isn't obvious.
Comment 1 Treeherder Robot 2012-12-03 01:55:31 PST
Standard8
https://tbpl.mozilla.org/php/getParsedLog.php?id=17551405&tree=Thunderbird-Trunk
TB Rev3 Fedora 12 comm-central debug test mozmill on 2012-12-03 01:06:12
slave: talos-r3-fed-005

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 2 Treeherder Robot 2012-12-03 02:09:50 PST
Standard8
https://tbpl.mozilla.org/php/getParsedLog.php?id=17551449&tree=Thunderbird-Trunk
TB Rev4 MacOSX Snow Leopard 10.6 comm-central opt test mozmill on 2012-12-03 01:33:50
slave: talos-r4-snow-051

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 3 Treeherder Robot 2012-12-03 02:09:55 PST
Standard8
https://tbpl.mozilla.org/php/getParsedLog.php?id=17551461&tree=Thunderbird-Trunk
TB Rev4 MacOSX Lion 10.7 comm-central opt test mozmill on 2012-12-03 01:33:50
slave: talos-r4-lion-009

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 4 Treeherder Robot 2012-12-03 02:09:59 PST
Standard8
https://tbpl.mozilla.org/php/getParsedLog.php?id=17551549&tree=Thunderbird-Trunk
TB Rev3 Fedora 12x64 comm-central debug test mozmill on 2012-12-03 01:04:51
slave: talos-r3-fed64-031

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 5 Mark Banner (:standard8) 2012-12-03 03:52:56 PST
hg bisect puts the blame on bug 814195.

I suspect there's something that probably needs updating with how we do our header display or something like that.
Comment 6 :aceman 2012-12-03 04:39:08 PST
Oh, it is in Core therefore we didn't see anything suspicious in c-c commits.
Comment 7 Treeherder Robot 2012-12-08 03:47:17 PST
mkmelin
https://tbpl.mozilla.org/php/getParsedLog.php?id=17684489&tree=Thunderbird-Trunk
TB Rev3 WINNT 5.1 comm-central opt test mozmill on 2012-12-06 14:00:39
slave: talos-r3-xp-014

TEST-UNEXPECTED-FAIL | c:\talos-slave\test\build\mozmill\multiple-identities\test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 8 Treeherder Robot 2012-12-08 03:50:40 PST
mkmelin
https://tbpl.mozilla.org/php/getParsedLog.php?id=17708212&tree=Thunderbird-Trunk
TB Rev3 Fedora 12x64 comm-central opt test mozmill on 2012-12-07 04:17:22
slave: talos-r3-fed64-040

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 9 Treeherder Robot 2012-12-08 03:51:05 PST
mkmelin
https://tbpl.mozilla.org/php/getParsedLog.php?id=17682150&tree=Thunderbird-Trunk
TB Rev3 Fedora 12x64 comm-central debug test mozmill on 2012-12-06 12:21:38
slave: talos-r3-fed64-029

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/message-window/test-commands.js | test-commands.js::test_copy_eml_message
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 10 Treeherder Robot 2012-12-08 03:52:46 PST
mkmelin
https://tbpl.mozilla.org/php/getParsedLog.php?id=17681418&tree=Thunderbird-Trunk
TB Rev3 Fedora 12 comm-central opt test mozmill on 2012-12-06 12:32:55
slave: talos-r3-fed-033

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/message-window/test-commands.js | test-commands.js::test_copy_eml_message
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 11 Treeherder Robot 2012-12-08 03:52:56 PST
mkmelin
https://tbpl.mozilla.org/php/getParsedLog.php?id=17682581&tree=Thunderbird-Trunk
TB Rev3 Fedora 12 comm-central debug test mozmill on 2012-12-06 12:45:42
slave: talos-r3-fed-055

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 12 :aceman 2012-12-08 09:47:56 PST
Mconley, I can see these nulls displayed while using the current trunk build. It happens if the To recipient has the yellow star beside the name in the header pane. The recipient is in an addressbook. For me, the recipient was in the Collected addresses addressbook. As soon as I deleted him from it, the address displayed properly in the msg header pane. I didn't even need to reselect the msg or anything.
Comment 13 :aceman 2012-12-08 09:58:46 PST
For the mentioned recipient address that gets passed in msgHdrViewOverlay.js::FormatDisplayName(), this function returns null. I'll 
check this out.
Comment 14 :aceman 2012-12-08 11:04:53 PST
Well, the result of FormatDisplayName function is not null but "null" (a string) now. And that is no longer falsy as we expect in later code.

It is because aDocumentNode.getAttribute("displayName") returns "null" (string). And that is because before that we .setAttribute("displayName", null) [not string]. Bz, is that something that the patch in bug 814195 intended?
Comment 15 :aceman 2012-12-08 11:08:42 PST
So it looks like we .setAttribute() to null (typeof = "Object"), but from.getAttribute() we get "null" (typeof = "string").
Comment 16 Peter Van der Beken [:peterv] 2012-12-08 11:41:05 PST
Yes, the behaviour changed to be more spec-compliant. You should set the attribute to the empty string instead of null.
Comment 17 :aceman 2012-12-08 11:51:53 PST
OK, thanks.

I wonder if this does not bite us at many more places.
Comment 18 :aceman 2012-12-08 12:40:19 PST
Created attachment 690126 [details] [diff] [review]
patch

After the Core patch .getAttribute of an attribute that does not exist returns "". It seems that is usable for us too, instead of null.
Comment 19 :aceman 2012-12-08 12:45:40 PST
I used .removeAttribute when the value of the attribute would be null. But we can set it to "" instead. Whatever squib decides.
Comment 20 Jim Porter (:squib) 2012-12-08 13:28:56 PST
(In reply to :aceman from comment #14)
> Well, the result of FormatDisplayName function is not null but "null" (a
> string) now. And that is no longer falsy as we expect in later code.

Are you sure about this? If the address isn't your identity and you don't have an AB card for it, it will return null. The only way it can return the empty string is if you have an AB card and either the email address from the mail header has no display name or the card's display name is blank.

(In reply to :aceman from comment #19)
> I used .removeAttribute when the value of the attribute would be null. But
> we can set it to "" instead. Whatever squib decides.

I think this should be equivalent to what you're doing now, since getAttribute on a non-existing attributes returns "" (at least in XUL):

  aEmailNode.setAttribute("fullAddress", aAddress.fullAddress || "");
Comment 21 Boris Zbarsky [:bz] 2012-12-08 13:35:47 PST
Just to clarify what changes: passing null to setAttribute used to convert it to "" internally and set the attribute to "".

That got changed in bug 814195 to follow the spec and convert null to "null", which matches other browsers.

GetAttribute(), on the other hand, did not change behavior.  It used to return the string that was set ("") and now returns the string that was set ("null").

Note that the behavior described in comment 20, where in XUL getAttribute of a nonexistent attribute returns "", is technically a bug: per spec getAttribute of a nonexistent attribute should in fact return null.  We do that for all non-XUL elements...
Comment 22 Jim Porter (:squib) 2012-12-08 13:41:03 PST
(In reply to Boris Zbarsky (:bz) from comment #21)
> Note that the behavior described in comment 20, where in XUL getAttribute of
> a nonexistent attribute returns "", is technically a bug: per spec
> getAttribute of a nonexistent attribute should in fact return null.  We do
> that for all non-XUL elements...

That's odd. I was just going by what MDN says: https://developer.mozilla.org/en-US/docs/DOM/element.getAttribute#Notes
Comment 23 :aceman 2012-12-08 13:48:05 PST
(In reply to Jim Porter (:squib) from comment #20)
> (In reply to :aceman from comment #14)
> > Well, the result of FormatDisplayName function is not null but "null" (a
> > string) now. And that is no longer falsy as we expect in later code.
> 
> Are you sure about this? If the address isn't your identity and you don't
> have an AB card for it, it will return null.
According to comment 12, there was a card for the address. But in that case 
FormatDisplayName first used the aHeaderDisplayName argument, which now was "null" string. As "PreferDisplayName" was not set in the card, the returned displayName stayed at the value of the string "null".

> The only way it can return the
> empty string is if you have an AB card and either the email address from the
> mail header has no display name or the card's display name is blank.

> I think this should be equivalent to what you're doing now, since
> getAttribute on a non-existing attributes returns "" (at least in XUL):
> 
>   aEmailNode.setAttribute("fullAddress", aAddress.fullAddress || "");
Yeah, this is shorter, I'll use this.
Comment 24 :aceman 2012-12-08 13:48:38 PST
Created attachment 690134 [details] [diff] [review]
patch v2
Comment 25 Jim Porter (:squib) 2012-12-08 14:21:59 PST
Comment on attachment 690134 [details] [diff] [review]
patch v2

Review of attachment 690134 [details] [diff] [review]:
-----------------------------------------------------------------

The code looks good. Don't change the comment though; you'll still get back null whenever there's no card for the address, which is what the comment talks about.

::: mail/base/content/msgHdrViewOverlay.js
@@ +1224,5 @@
>  /**
>   * Take an email address and compose a sensible display name based on the
>   * header display name and/or the display name from the address book. If no
>   * appropriate name can be made (e.g. there is no card for this address),
> + * returns "".

Please don't change this comment. The old way is correct.

@@ +1230,5 @@
>   * @param aEmailAddress       the email address to format
>   * @param aHeaderDisplayName  the display name from the header, if any
>   * @param aContext            the field being formatted (e.g. "to", "from")
>   * @param aCard               the address book card, if any
> + * @return                    The formatted display name, or the empty string.

Likewise here.
Comment 26 Jim Porter (:squib) 2012-12-08 14:26:19 PST
If you prefer, you can adjust the implementation of FormatDisplayName to return null instead of the empty string when there's a card.
Comment 27 :aceman 2012-12-08 14:30:45 PST
That's what I wanted to say:) It can return null, "", or an address. I'll try to merge the null and "".
Comment 28 :aceman 2012-12-08 15:12:44 PST
What would you prefer in case aHeaderDisplayName is empty and there is a card but the Display name in it is empty?
Comment 29 neil@parkwaycc.co.uk 2012-12-08 15:21:33 PST
(In reply to Boris Zbarsky from comment #21)
> Just to clarify what changes: passing null to setAttribute used to convert
> it to "" internally and set the attribute to "".
> 
> That got changed in bug 814195 to follow the spec and convert null to
> "null", which matches other browsers.
Is there an easy way of tweaking my build to assert whenever chrome code tries to pass null to setAttribute, as this new behaviour is almost certainly useless?
Comment 30 :aceman 2012-12-08 15:35:04 PST
Neil, can you see if SM needs the same fix? It also sets these attributes unconditionally in updateEmailAddressNode() and then reads it in  UpdateEmailNodeDetails().
Comment 31 Jim Porter (:squib) 2012-12-08 16:27:22 PST
(In reply to :aceman from comment #28)
> What would you prefer in case aHeaderDisplayName is empty and there is a
> card but the Display name in it is empty?

I'd do something like this:

1262   if (card) {
1263     if (!displayName && aHeaderDisplayName)
1264       displayName = aHeaderDisplayName;
1265 
1266     // getProperty may return a "1" or "0" string, we want a boolean
1267     if (!displayName || card.getProperty("PreferDisplayName", true) != false)
1268       displayName = card.displayName || null;
1269   }
Comment 32 Boris Zbarsky [:bz] 2012-12-08 18:42:53 PST
> I was just going by what MDN says

MDN is talking about the old DOM Core spec, which as it notes does not reflect reality.  Spec's been updated to do so...

> Is there an easy way of tweaking my build to assert whenever chrome code tries to pass
> null to setAttribute

You could check nsContentUtils::IsCallerChrome() && DOMStringIsNull(aValue) in Element::SetAttribute.
Comment 33 Boris Zbarsky [:bz] 2012-12-08 18:45:38 PST
I fixed the MDN docs.
Comment 34 :aceman 2012-12-09 05:32:32 PST
Which ones?
https://developer.mozilla.org/en-US/docs/DOM/element.setAttribute is not clear about it.
Comment 35 :aceman 2012-12-09 05:37:27 PST
Created attachment 690186 [details] [diff] [review]
patch v3
Comment 36 neil@parkwaycc.co.uk 2012-12-09 07:09:32 PST
(In reply to Boris Zbarsky from comment #32)
> > Is there an easy way of tweaking my build to assert whenever chrome code tries to pass
> > null to setAttribute
> You could check nsContentUtils::IsCallerChrome() && DOMStringIsNull(aValue)
> in Element::SetAttribute.
Doesn't work, aValue is already "null" by then. Fortunately we don't have many people trying to set an attribute to "null" so I just used EqualsLiteral.

(In reply to aceman from comment #30)
> Neil, can you see if SM needs the same fix? It also sets these attributes
> unconditionally in updateEmailAddressNode() and then reads it in 
> UpdateEmailNodeDetails().
Looks like we do. My assertion also found one other caller - in mailWindow.js myDefaultStatus defaults to null when it should be "" (I think you don't notice because after the start page loads it gets correctly reset to "").
Comment 37 Jim Porter (:squib) 2012-12-09 12:26:25 PST
Comment on attachment 690186 [details] [diff] [review]
patch v3

Looks good, assuming all the tests pass.
Comment 38 Treeherder Robot 2012-12-09 12:34:33 PST
mkmelin
https://tbpl.mozilla.org/php/getParsedLog.php?id=17761872&tree=Thunderbird-Trunk
TB Rev4 MacOSX Snow Leopard 10.6 comm-central opt test mozmill on 2012-12-09 08:43:27
slave: talos-r4-snow-048

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 39 :aceman 2012-12-09 12:54:18 PST
The test in the summary does pass now.

Neil, I could blindly do a patch for SM but without testing. It would probably be better if somebody from SM could do it. Will you create a new bug or do you make the patch here?
Comment 40 Treeherder Robot 2012-12-10 01:21:43 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17766979&tree=Thunderbird-Try
TB Rev3 WINNT 5.1 try-comm-central opt test mozmill on 2012-12-09 15:56:32
slave: talos-r3-xp-085

TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\mozmill\multiple-identities\test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 41 Treeherder Robot 2012-12-10 01:21:55 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17767026&tree=Thunderbird-Try
TB Rev3 WINNT 6.1 try-comm-central opt test mozmill on 2012-12-09 15:56:06
slave: talos-r3-w7-062

TEST-UNEXPECTED-FAIL | c:\talos-slave\test\build\mozmill\multiple-identities\test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 42 Treeherder Robot 2012-12-10 01:22:24 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17766803&tree=Thunderbird-Try
TB Rev3 Fedora 12 try-comm-central opt test mozmill on 2012-12-09 15:34:15
slave: talos-r3-fed-026

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/message-window/test-commands.js | test-commands.js::test_copy_eml_message
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 43 Treeherder Robot 2012-12-10 01:22:42 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17766989&tree=Thunderbird-Try
TB Rev3 Fedora 12 try-comm-central debug test mozmill on 2012-12-09 15:36:05
slave: talos-r3-fed-041

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/account/test-account-actions.js | test-account-actions.js::test_account_actions
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 44 Treeherder Robot 2012-12-10 01:23:05 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17767109&tree=Thunderbird-Try
TB Rev3 Fedora 12x64 try-comm-central debug test mozmill on 2012-12-09 15:36:13
slave: talos-r3-fed64-057

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 45 Treeherder Robot 2012-12-10 01:23:18 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17766720&tree=Thunderbird-Try
TB Rev4 MacOSX Snow Leopard 10.6 try-comm-central opt test mozmill on 2012-12-09 15:33:13
slave: talos-r4-snow-064

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 46 Treeherder Robot 2012-12-10 01:23:35 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17766724&tree=Thunderbird-Try
TB Rev4 MacOSX Lion 10.7 try-comm-central opt test mozmill on 2012-12-09 15:33:06
slave: talos-r4-lion-033

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 47 Treeherder Robot 2012-12-10 01:37:32 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17765484&tree=Thunderbird-Try
TB Rev3 Fedora 12x64 try-comm-central debug test mozmill on 2012-12-09 13:00:14
slave: talos-r3-fed64-033

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/message-window/test-commands.js | test-commands.js::test_copy_eml_message
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 48 Treeherder Robot 2012-12-10 01:37:50 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17765320&tree=Thunderbird-Try
TB Rev3 Fedora 12x64 try-comm-central opt test mozmill on 2012-12-09 13:01:06
slave: talos-r3-fed64-036

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/message-window/test-commands.js | test-commands.js::test_copy_eml_message
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 49 Treeherder Robot 2012-12-10 01:38:13 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17765442&tree=Thunderbird-Try
TB Rev3 Fedora 12 try-comm-central debug test mozmill on 2012-12-09 13:05:13
slave: talos-r3-fed-035

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 50 Treeherder Robot 2012-12-10 01:38:28 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17765530&tree=Thunderbird-Try
TB Rev4 MacOSX Snow Leopard 10.6 try-comm-central opt test mozmill on 2012-12-09 13:41:27
slave: talos-r4-snow-045

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 51 Treeherder Robot 2012-12-10 01:39:04 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17765534&tree=Thunderbird-Try
TB Rev4 MacOSX Lion 10.7 try-comm-central opt test mozmill on 2012-12-09 13:41:27
slave: talos-r4-lion-061

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/mozmill/multiple-identities/test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 52 Treeherder Robot 2012-12-10 01:41:12 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17765441&tree=Thunderbird-Try
TB Rev3 WINNT 6.1 try-comm-central opt test mozmill on 2012-12-09 13:20:37
slave: talos-r3-w7-071

TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\mozmill\multiple-identities\test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 53 Treeherder Robot 2012-12-10 01:41:23 PST
Archaeopteryx
https://tbpl.mozilla.org/php/getParsedLog.php?id=17765417&tree=Thunderbird-Try
TB Rev3 WINNT 5.1 try-comm-central opt test mozmill on 2012-12-09 13:20:37
slave: talos-r3-xp-027

TEST-UNEXPECTED-FAIL | c:\talos-slave\test\build\mozmill\multiple-identities\test-display-names.js | test-display-names.js::test_no_header_name_in_abook_no_pdn
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Comment 54 Mark Banner (:standard8) 2012-12-10 03:19:33 PST
Many thanks for fixing this aceman!

https://hg.mozilla.org/comm-central/rev/a86f2efe5ffa

Note You need to log in before you can comment on or make changes to this bug.