Typing "help" in Web Console redirects to 404 not found page

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: Console
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: Johan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

 1. Open the Firefox console (Ctrl + Shift + K).
 2. Type "help" (without the quotes)
 3. Press the Enter key



Actual results:

I got redirected to a 404 Not Found error page.

These are the HTTP requests sent:

[11:32:41.254] GET https://developer.mozilla.org/AppLinks/WebConsoleHelp?locale=nl [HTTP/1.1 301 MOVED PERMANENTLY 442ms]
[11:32:41.833] GET https://developer.mozilla.org/nl/AppLinks/WebConsoleHelp?locale=nl [HTTP/1.1 404 NOT FOUND 515ms]


Expected results:

I expect some documentation about using the Web Console.
Thanks for reporting this Johan.

I am going to move this over to the Firefox Developer Tools team as I do not see the same behavior at my machine. That said, we can may be able to handle situations like this on our end. We will look into that with bug 819099.

Developer Tools:

I cannot reproduce the issue in comment 0. On my machine, when I type "help" into the Firefox Console, I am directed to https://developer.mozilla.org/docs/Tools/Web_Console/Helpers which ultimately redirects me to https://developer.mozilla.org/en-US/docs/Tools/Web_Console/Helpers. Any idea why Johan is being directed to another address?
Status: UNCONFIRMED → NEW
Component: Landing pages → Developer Tools: Console
Ever confirmed: true
Product: Mozilla Developer Network → Firefox
Johan seems to run Firefox 17, what version are you using John? This was fixed in Firefox 18 (bug 703041), but never made it into Aurora. Unfortunately we can't spin a hotfix release for such a minor bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.