[Browser] Cannot scroll to the bottom of some web pages unless you zoom in the page

VERIFIED FIXED in B2G C3 (12dec-1jan)

Status

Firefox OS
Gaia::Browser
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: rudyl, Assigned: daleharvey)

Tracking

unspecified
B2G C3 (12dec-1jan)
x86
Mac OS X

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(5 attachments)

Created attachment 687693 [details]
screenshot for the browser stuck point

STR
====
1. Go to MDN with Firefox OS browser 
   https://developer.mozilla.org/en-US/

2. Try to scroll down to the bottom of the page

expected result:
   You could scroll down to see a select for languages.

Actual:
   Can scroll down but would be stuck at a point (see the attached screenshot) that the select could not be seen.
   Note: If you zoom in the page but pinch gesture then you can scroll down.

--
I think this is a blocking issue since it is a general issue for web browsing - also could be reproduced with: http://tw.yahoo.com.
Assignee: nobody → ben
blocking-basecamp: ? → +
Priority: -- → P2
I haven't been able to reproduce this. Does the problem persist after you kill the browser app? I wonder if it's getting into some weird state where the address bar is shown but the iframe is still enlarged.
It seems that this issue has been fixed with the latest code.

Build ID: 20121204062808 on Otoro
Gaia rev:
173475451f4cecad4b5b1737cd38757c680b4be3

Ben, thanks for taking a look at this.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Hi, I found that I could still reproduce this issue with the latest build by following the steps,

STR
====
1. Go to google.com
2. Type "mdn" in the search input box.
   - Press the "enter" keyboard on the virtual keyboard.
3. Click MDN in the search result.
4. Try to scroll to the bottom of the page.

Expected result:
   You could not scroll down to see a select for languages.

Actual:
   Can scroll down but would be stuck at a point (see the attached screenshot) that the select could not be seen.
   
Note: When this issue occurred, the awesome would not disappear when you scroll down.

Gecko: build ID 20121213075759
Gaia: commit 1f818a4bdd08d1554cc2e8063a4ab23526e36c0a
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I still can't reproduce this, but from your latest description, comment 1 seems even more likely.

Updated

5 years ago
Target Milestone: --- → B2G C3 (12dec-1jan)

Comment 5

5 years ago
Created attachment 693264 [details]
screenshot

Reproduced this on 12-17 unagi build.  20121217070202

STR:
1) goto google.tw
2) search MDN, and click the first link returned (http://www.mdn.co.jp/di/)
3) as the content is loading, start panning down the screen
4) eventually, the screen just locks up before the page finishes loading to the footer.   My browser then gets stuck and unresponsive, i have to force kill the browser app.
Ben's out until after C3, reassigning to Dale. Dale, let your manager know if you need this assigned away to someone else.
Assignee: ben → dale

Comment 7

5 years ago
I'm seeing the same or a similar issue on the mobile Wikipedia site; often I can't scroll to the page footer line at the bottom, which says 'Wikipedia' and can be expanded to show some additional options.

Example: http://test.m.wikipedia.org/wiki/San_Francisco

In Firefox for Android, I can scroll all the way to the bottom -- on my Firefox OS test device, the final footer is cut off (apparently behind the toolbar?)

Comment 8

5 years ago
Created attachment 693617 [details]
Bottom of Wikipedia 'San Francisco' article on Android, footer visible

Comment 9

5 years ago
Created attachment 693619 [details]
Bottom of Wikipedia 'San Francisco' article on Firefox OS device, footer invisible
Created attachment 694869 [details]
Show address bar on page navigation properly, and ensure events are captured
Attachment #694869 - Flags: review?(21)
Comment on attachment 694869 [details]
Show address bar on page navigation properly, and ensure events are captured

stealing the review
Attachment #694869 - Flags: review?(21) → review?(felash)
Comment on attachment 694869 [details]
Show address bar on page navigation properly, and ensure events are captured

commented on https://github.com/mozilla-b2g/gaia/pull/7143/files

r+ with the other small problems fixed and if possible one or two unit tests ;)
Attachment #694869 - Flags: review?(felash) → review+
Addressed nits, merged in https://github.com/mozilla-b2g/gaia/commit/12b4551f11d330f4fe6d2b2927327305769a7ca3
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 14

5 years ago
Verified Fixed in Unagi build #20121231070201
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.