Open external applications on specific links as default

RESOLVED DUPLICATE of bug 851693

Status

()

Firefox for Android
General
--
enhancement
RESOLVED DUPLICATE of bug 851693
5 years ago
2 years ago

People

(Reporter: Frederik Niedernolte, Unassigned)

Tracking

20 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

Click on a link for Google Play Store / YouTube / etc.


Actual results:

The web page opens in a new tab


Expected results:

The installed application opens with the specific video / application / link.
This behaviour is already possible with a long-press on the link -> context menu but it would make more sense to make it default to open those links directly with the installed application.

Updated

5 years ago
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Whiteboard: DUPEME
(Reporter)

Updated

5 years ago
Version: Firefox 18 → Firefox 20
I believe the context-menu was added so that it provides the user with a choice of path. I think this is wont-fix; Mark?
Severity: normal → enhancement
(Reporter)

Comment 2

5 years ago
I know but what about changing that behaviour vice versa?
Would be more intuitive.
Ian, wontfix?
Flags: needinfo?(ibarlow)
From an Android integration standpoint, I would be more inclined to show the "Open this app in..." menu when you tap a link to the Play Store. 

I'd be interested to hear what Mark thinks too, though.
Flags: needinfo?(ibarlow)
re; android integration stuff
Flags: needinfo?(mark.finkle)
In general, our view on this concept is: If the link is HTTP/HTTPS, it opens in Firefox. Other link schemes, like market://, should prompt for the registered native app.

We are looking for ways to allow users to be shown "open this in X?", but in an unobtrusive way.
Flags: needinfo?(mark.finkle)

Comment 7

3 years ago
There should be an option to adjust the default behavior so it's Win Win for everyone.

Firefox Settings Menu:
Default Option 1: Open in Firefox
Default Option 2: Open in 3rd party app
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 851693
You need to log in before you can comment on or make changes to this bug.