Need method of searching history from the History panel

RESOLVED DUPLICATE of bug 114127

Status

--
enhancement
RESOLVED DUPLICATE of bug 114127
18 years ago
14 years ago

People

(Reporter: bugs, Assigned: mpt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

IE6 on Windows has a "Search" button in its history panel which hides the
history listing and displays a search query field. You type in a query and hit
Search, and it displays the results below. 

IE allows you to return to a regular view of the history by having a "View"
menubutton adjacent to the Search button, which offers a list of sort options
for viewing the history list. Their implementation suggests a deck with two
views, one with a standard history list sorted per the View menubutton, and
another accessed via the search button, with a search field and a view for
displaying results.

Another alternative is to simply pop up the Search History dialog. If we do
that, where do we put the results? Do we open a history window with the results?
Or do we show them in the sidebar, and offer some mechanism for returning to the
original sorted display? 

I can see pros and cons for each approach. I'm filing this bug because one way
or another, I want to be able to search my history without first having to 
1) Open history (Tasks->Tools->History) (3 clicks) 
2) Open find (Edit->Find) (2 clicks)
<do search>

Compared to IE, where it's 
1) Open History sidebar (one click on button on toolbar)
2) Open Search (one click on search button)<do search>

IE's is more discoverable, and more useful currently.

Comment 2

18 years ago
Searching history from the History Pane yields junk results in Build ID: 2001060703

PS The search feature for history was there in IE5.0 also.

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 114127 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
*** Bug 172614 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Component: User Interface Design → Browser-General

Comment 5

16 years ago
IE's is more useful, it lets you search content, not just "title" and "location".
see also 126621.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.