Closed Bug 817602 Opened 7 years ago Closed 7 years ago

Add various firefox-appdir definitions to platform tests

Categories

(Firefox :: General, defect)

x86_64
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 755724

People

(Reporter: jimm, Assigned: jimm)

References

Details

Attachments

(1 file)

Certain tests in core rely on firefox prefs to run. Bug 810617 added a way to add a relative app dir for test runs to the xpcshell.ini manifests. When we split browser and gre, we'll need to land a set of firefox-appdir entries as well to keep tests working. (Assuming we haven't removed all of the app pref dependencies by then.)
Attached patch current list v.1Splinter Review
Assignee: nobody → jmathies
plus toolkit/components/downloads/test/unit/xpcshell.ini:

https://hg.mozilla.org/projects/elm/rev/cd02ae5a8af5
and browser/components/sessionstore/test/unit/xpcshell.ini, now.
Note: it would be nice not to have to set this in all xpcshell.ini files under browser/
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: metro-build
You need to log in before you can comment on or make changes to this bug.