[Settings] Settings - Sound -Slider default value not at 50%

RESOLVED FIXED in 2.1 S5 (26sep)

Status

RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: mlevin, Assigned: gasolin)

Tracking

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g18 affected, b2g18-v1.0.1 affected, b2g-v1.3T affected, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: permafail, [p=1])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 687831 [details]
Volume Sliders not at 50% by default

Unagi Build ID: 20121203070719 

See attachment. 

Steps: 
1. Go to Settings - Sounds for the first time after upgrading the phone to view the sound defaults: 

Expected: Volume slider at 50% by default. 

Actual: Most volume sliders are at 75% default. "Content" slider is at 100%

Updated

6 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM

Comment 1

6 years ago
From duplicate bug 822896: 
This issue still reproduces on Unagi device.
Build ID: 20130130070201
Kernel: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4593f3e765eb
Gaia   f7f5a0cd17e3d04308cc5850b254947e127122b9

UCID: set-120
TC: #2904
https://moztrap.mozilla.org/runtests/run/712/env/296/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=2904

Updated

6 years ago
Duplicate of this bug: 822896

Comment 3

6 years ago
Issue still reproduces on Unagi device
Build ID: 20130220070204
December 5th Kernel
Gaia:   b8bd76b1110417ef43a39ae28a2eeffbce1eda11
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/140d06fc3397

Navigating to the "Sound" menu option after a phone reset to simulate a first time user reveals the phone sound volume not at 50% default.

Comment 4

6 years ago
By default, the phone sound volume is not at 50% after OTA. The user sees the phone volume is all the way up to 100%. Issue repros on 

Unagi Build ID: 20130322070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/4931ec89ebbe
Gaia: 85fd164691bb852f1cfaf82405df4380629ced6e
Inari build: 20130416070200
Kernel: Feb 21st
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6bac24e14538
Gaia   c883af5ecd0998f78d9aaa4c2337c842e1dbb5a0

UCID
https://moztrap.mozilla.org/manage/cases/?&pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-id=2904

By default the volume is maxed on the Inari device.
status-b2g18: --- → affected
Whiteboard: inarirun1

Updated

6 years ago
status-b2g18-v1.0.1: --- → affected
(Reporter)

Comment 6

6 years ago
Same issue reproduces on Leo Build ID: 20130411070205.

Environmental  Variables:
Kernel Date: Mar 15
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/f671fa539473
Gaia: e7e338a765e22334b40ced41489a785941382c66

Repro frequency: 2/2 100%
Test Suite Name: Settings - Sound
UCID: set-120
Link to failed test case: https://moztrap.mozilla.org/runtests/run/1117/env/314/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=2904&filter-suite=192
Q Analysts Test Team Priority: 3

Updated

6 years ago
Whiteboard: inarirun1 → inarirun1, leorun1

Updated

6 years ago
Whiteboard: inarirun1, leorun1 → inarirun1, leorun1, inarirun2

Updated

6 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 7

6 years ago
What is the nature of the UX need here? Please let us know.

Updated

6 years ago
Flags: needinfo?(rmacdonald)

Updated

6 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)

Updated

6 years ago
Whiteboard: inarirun1, leorun1, inarirun2 → inarirun1, leorun1, inarirun2, leorun3

Comment 8

6 years ago
Reassigning to Casey since Settings and audio are his domain. Casey, please reassign as appropriate (i.e. if this should be Neo).
Flags: needinfo?(rmacdonald) → needinfo?(kyee)

Updated

5 years ago
QA Contact: ckreinbring

Comment 9

5 years ago
Reassigning to Neo.
Flags: needinfo?(kyee) → needinfo?(nhsieh)

Updated

5 years ago
Whiteboard: inarirun1, leorun1, inarirun2, leorun3 → inarirun1, leorun1, inarirun2, leorun3, burirun1

Updated

5 years ago
Whiteboard: inarirun1, leorun1, inarirun2, leorun3, burirun1 → inarirun1, leorun1, inarirun2, leorun3, burirun1,burirun2

Comment 10

5 years ago
I try to reset sample phone and check the volumn.. It's 100% !
Please set the default value to 50%. Thanks
Flags: needinfo?(nhsieh)

Updated

5 years ago
Whiteboard: inarirun1, leorun1, inarirun2, leorun3, burirun1,burirun2 → inarirun1, leorun1, inarirun2, leorun3, burirun1,burirun2, burirun3

Updated

5 years ago
Whiteboard: inarirun1, leorun1, inarirun2, leorun3, burirun1,burirun2, burirun3 → permafail
status-b2g-v1.4: --- → affected
status-b2g-v1.3T: --- → affected
status-b2g-v2.0: --- → affected
(Assignee)

Comment 11

4 years ago
based on Neo's comment, I think it should be in backlog...
Flags: needinfo?(jelee)
Flags: needinfo?(hochang)

Comment 12

4 years ago
thanks for bringing this up.
blocking-b2g: --- → backlog
Flags: needinfo?(hochang)

Comment 13

4 years ago
ok, let's revisit this issue soon!
Flags: needinfo?(jelee)
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(Assignee)

Comment 14

4 years ago
Created attachment 8491242 [details] [review]
pull request redirect to github

change the default volume to 8 (MAX 15) in default settings
Attachment #8491242 - Flags: review?(ejchen)
Comment on attachment 8491242 [details] [review]
pull request redirect to github

Fred,

please modify the default value in sound.html at the same time to make them consistent.

Thanks !
Attachment #8491242 - Flags: review?(ejchen)
(Assignee)

Comment 16

4 years ago
Comment on attachment 8491242 [details] [review]
pull request redirect to github

thanks for catch that! please kindly review it again.
Attachment #8491242 - Flags: review?(ejchen)
Comment on attachment 8491242 [details] [review]
pull request redirect to github

Thanks Fred ! r+
Attachment #8491242 - Flags: review?(ejchen) → review+
(Assignee)

Comment 18

4 years ago
merged https://github.com/mozilla-b2g/gaia/commit/d69f170bf90d496c5f26b0f5c0a000922a323fbd

thanks!
Assignee: nobody → gasolin
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: permafail → permafail, [p=1]
Target Milestone: --- → 2.1 S5 (26sep)

Updated

4 years ago
Duplicate of this bug: 1093518
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.