Modify client to handle clock skew for If-Modified-Since header

RESOLVED FIXED in Firefox 18

Status

Android Background Services
Product Announcements
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jrconlin, Assigned: rnewman)

Tracking

unspecified
mozilla20
ARM
Android

Firefox Tracking Flags

(firefox18+ fixed, firefox19+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Some client may have an incorrectly set clock. This can cause duplication of campaign messages or some campaign messages not being seen by the client.

The requested work-around is to have the client echo the "Date" header contained in the server response back as the "If-Modified-Since" header.
(Reporter)

Updated

6 years ago
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
(Assignee)

Comment 1

6 years ago
https://github.com/mozilla-services/android-sync/pull/274
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Component: Server: Product Announcements Campaign Manager → Android: Product Announcements
OS: Windows 7 → Android
Hardware: x86_64 → ARM
(Assignee)

Comment 2

6 years ago
Created attachment 688105 [details] [diff] [review]
Patch against inbound. v1

See also pull req, 'cept this is rebased onto master to avoid landing Sync auth changes.
Attachment #688105 - Flags: review?(nalexander)
This looks good on rnewmans test build.  I set the device clock forward several hours. I still get the announcement.
QA Contact: twalker

Updated

6 years ago
tracking-firefox18: ? → +
tracking-firefox19: ? → +
(Assignee)

Comment 4

6 years ago
Created attachment 688359 [details] [diff] [review]
Reviewed patch. v2

This has been reviewed, and incorporates review comments. nalexander, please set flag.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  -- Feature not yet landed. Server/client integration testing is finishing up now.

User impact if declined: 
  -- Users with a clock that's behind will see some announcements twice. Users with a clock that's fast will not see some announcements.

Testing completed (on m-c, etc.): 
  -- Tracy has verified a build. Just landed on inbound.

Risk to taking this patch (and alternatives if risky): 
  -- Nil. Code is currently preffed off; these are changes revealed by testing that we want to make before preffing on.

String or UUID changes made by this patch: 
  -- None.
Attachment #688105 - Attachment is obsolete: true
Attachment #688105 - Flags: review?(nalexander)
Attachment #688359 - Flags: review?(nalexander)
Attachment #688359 - Flags: approval-mozilla-beta?
Attachment #688359 - Flags: approval-mozilla-aurora?
Comment on attachment 688359 [details] [diff] [review]
Reviewed patch. v2

Review of attachment 688359 [details] [diff] [review]:
-----------------------------------------------------------------

reviewed in github, and review comments addressed.
Attachment #688359 - Flags: review?(nalexander) → review+
https://hg.mozilla.org/mozilla-central/rev/dafb0368260c
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Attachment #688359 - Flags: approval-mozilla-beta?
Attachment #688359 - Flags: approval-mozilla-beta+
Attachment #688359 - Flags: approval-mozilla-aurora?
Attachment #688359 - Flags: approval-mozilla-aurora+
Component: Android: Product Announcements → Product Announcements
Product: Mozilla Services → Android Background Services

Updated

5 years ago
QA Contact: twalker
You need to log in before you can comment on or make changes to this bug.