Web Console not always opening or closing

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Console
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Landis Reed, Unassigned)

Tracking

({steps-wanted})

19 Branch
x86
Linux
steps-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 688010 [details]
FF-Aurora-19.x-WebInspector-Not-allways-opening-Or-closing_03.12.12-01.png

User Agent: Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/20121203 Firefox/19.0
Build ID: 20121203042014

Steps to reproduce:

Ctrl+Shift+K


Actual results:

sometimes 'Web Console' does Not open or opens only as an 10px bar at bottom of window, but can be dragged 'open' from top border.
When i repeat C+Sh+K to 'close' Web Console, it will Not close and clicking on the 'X' of WC, does Not close it, either.


Expected results:

Web Console should open in the bottom of window (default location, checked) to about 120px or so and should close with a second Ctrl+Shift+K key press or at the very least, by clicking the 'X' on the 'title bar' of the Console window.
(Reporter)

Comment 1

5 years ago
When WC does open and 'closes' with a second C+Sh+K combination, it does Not close all the way. It remains 'open', but smaller at the bottom of the window and will Not re-open to 120px height until that window (tab) is close and a new or another window (tab) is used.
see second screen capture (FF-Aurora-19.x-WebInspector-Not-allways-opening-Or-closing_03.12.12-02.png )
(Reporter)

Comment 2

5 years ago
Created attachment 688017 [details]
second capture of Web Console Not closeing or re-opening
(Reporter)

Comment 3

5 years ago
at times, when WC 'doesn't open' it seems that it's not opening. 
it's when a site, page has a fixed css at the bottom of the window that doesn't 'move up' when WC is opened and wants to 'claim' that location at bottom of window.
An example of this is at Yahoo.com once a search has been submitted and yahoo's whatever bar appears at bottom (i assume for registered and logged in users like myself).
see attached screenshot..
Landis.
(Reporter)

Comment 4

5 years ago
Created attachment 688058 [details]
third captuer at site like Yahoo using fixed bottom css box

Comment 5

5 years ago
Did you try with a new profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Updated

5 years ago
Component: Untriaged → Developer Tools: Console
Landis: can you provide us with steps to reproduce the bug? On yahoo or any other site.

Thank you for the bug report!

Comment 7

5 years ago
Landis, can you please answer comment 5 and comment 6?
Flags: needinfo?(landis)
(Reporter)

Comment 8

5 years ago
(In reply to Mihai Sucan [:msucan] from comment #6)
> Landis: can you provide us with steps to reproduce the bug? On yahoo or any
> other site.
> 
> Thank you for the bug report!

Yes I will, right now.
Component: Developer Tools: Console → Untriaged
Flags: needinfo?(landis)
(Reporter)

Comment 9

5 years ago
(In reply to Loic from comment #5)
> Did you try with a new profile?
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles

With a clean 'default' profile, WC in Aurora 19.x seems to work normally, even at yahoo..
I will want to run the default profile for the day to make sure it's not a cummilative affect of cache or memory like too many tabs or cached images.
Landis.
Thank you. Please let me know what you find. Maybe you have incompatible extensions?
Component: Untriaged → Developer Tools: Console
OS: Linux → All
Hardware: x86 → All

Comment 11

5 years ago
Could reproduce on 19.0a2 (2012-12-01).

Comment 12

5 years ago
Created attachment 688407 [details]
Web Console not closing

Comment 13

5 years ago
(In reply to rctgamer3 from comment #11)
> Could reproduce on 19.0a2 (2012-12-01).

Linux, too?
(Reporter)

Comment 14

5 years ago
WC seems to be working in 19.0a2 'default' (new) profile.
most pages do not have any data in WC when Ctrl+Shift+K is pressed to activate the Console.
I was sure All pages had some data like my page landisreed.com/pages/ColorCodes.php.

Also, i thought about an extention / add-on i use called www.tran from http://translate.ua/ which resides at bottom of window and is activated via Ctrl+M or context menu.

I installed the add-on and have Not experienced any of the close/no close issue here.
I'll keep using the default profile today and let you know if I find, notice anything.
Landis.
My hunch is that this bug is not tied to a specific platform.
Whiteboard: [steps to reproduce needed]
(Reporter)

Comment 16

5 years ago
could it have to do with the 'new' resize feature in console? 
i remember seeing it, but can't find the press release. it was about rel 14
Landis
Component: Developer Tools: Console → Untriaged
OS: All → Linux
Hardware: All → x86
(Reporter)

Comment 17

5 years ago
Also, if I use Shift+F2 to bring up Command Line Console, and click on Web Console 'button', WC appears above Console and if I use Ctrl+Shift+K to collapse WC, it remains visible with same 10px height as if invoked w/o Command Console.
Landis.
(In reply to Landis Reed from comment #16)
> could it have to do with the 'new' resize feature in console? 
> i remember seeing it, but can't find the press release. it was about rel 14
> Landis

resize feature? what do you mean?

(In reply to Landis Reed from comment #17)
> Also, if I use Shift+F2 to bring up Command Line Console, and click on Web
> Console 'button', WC appears above Console and if I use Ctrl+Shift+K to
> collapse WC, it remains visible with same 10px height as if invoked w/o
> Command Console.
> Landis.

Which version of firefox do you use in this case? Do you always reproduce this issue?

Also, please don't change the component to Untriaged. Thanks!
Component: Untriaged → Developer Tools: Console
(Reporter)

Comment 19

5 years ago
(In reply to Mihai Sucan [:msucan] from comment #18)
> (In reply to Landis Reed from comment #16)
> > could it have to do with the 'new' resize feature in console? 
> > i remember seeing it, but can't find the press release. it was about rel 14
> > Landis
> 
> resize feature? what do you mean?
> 
> (In reply to Landis Reed from comment #17)
> > Also, if I use Shift+F2 to bring up Command Line Console, and click on Web
> > Console 'button', WC appears above Console and if I use Ctrl+Shift+K to
> > collapse WC, it remains visible with same 10px height as if invoked w/o
> > Command Console.
> > Landis.
> 
> Which version of firefox do you use in this case? Do you always reproduce
> this issue?
> 
> Also, please don't change the component to Untriaged. Thanks!

I recall, not to long ago, an article at mozilla.org that touted the 'new resizable' console window.... You can grab the edge and resize the height, i guess.
Component: Developer Tools: Console → Untriaged
(Reporter)

Comment 20

5 years ago
perhaps this is what i recall reading..
https://developer.mozilla.org/en-US/docs/Tools/Web_Console?redirectlocale=en-US&redirectslug=Using_the_Web_Console

the text, 'new resize bar' feature is under the first image (screen cap of the console)
Landis.

Updated

5 years ago
Component: Untriaged → Developer Tools: Console
Would like to know if the recent changes (the toolbox) have fixed this bug. Can anyone confirm this for us?
Flags: needinfo?

Comment 22

5 years ago
Tested this on Firefox 19 beta 3 and the 01/24 Aurora, both on Ubuntu 12.04 32bit.

I managed to reproduce the issue on beta, but only once in about 20-30 tries. It didn't reproduce at all on Aurora.

The profile I used on both builds is not too dirty, but it's not new either (no add-ons, themes, chaged prefs; only some history).
Flags: needinfo?

Updated

5 years ago
Keywords: steps-wanted
Whiteboard: [steps to reproduce needed]
so this should be fixed in aurora with the addition of the toolbox.

Would like to know what caused this bug originally and some steps to reproduce, but I'm going to mark it closed so we can move on.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 24

5 years ago
Yes, it seems to be 'fixed' in my nightly build (20.0a2 (2013-01-27)) of Aurora.

thanks, 
Landis.
You need to log in before you can comment on or make changes to this bug.