JavaScript Error: "not well-formed" when Gaia loads after reboot

RESOLVED DUPLICATE of bug 816149

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 816149
5 years ago
4 years ago

People

(Reporter: John Hammink, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
# Environment
Unagi
Nightly build 12/2/2012
Unagi BuildID= 20121202070809
Gecko - b7a71a10d566babce419b4fde0f6be602bc540eb
Gaia  - f48b93eafbeb3f93c9575b8bca733113ee611a52

When booting or rebooting the phone (either into FTE or directly to home/lockscreen) I am seeing a number of "not well formed" JS errors in logcat.

12-03 23:49:54.254: ERROR/(113): cby, conn_id = 0, client_id = 4, service_id = 1
12-03 23:49:54.314: ERROR/GeckoConsole(109): AUS:SVC UpdateService:_offlineStatusChanged - network is online, forcing another background check
12-03 23:49:54.314: ERROR/GeckoConsole(109): AUS:SVC UpdateService:_attemptResume
12-03 23:49:54.314: ERROR/GeckoConsole(109): AUS:SVC Checker: checkForUpdates, force: false
12-03 23:49:54.324: ERROR/GeckoConsole(109): AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
12-03 23:49:54.334: ERROR/GeckoConsole(109): AUS:SVC Checker:checkForUpdates - sending request to: http://update.boot2gecko.org/nightly/update.xml
12-03 23:49:54.594: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://calculator.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.604: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://browser.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.614: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://feedback.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.624: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://costcontrol.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.634: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://fm.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.644: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://homescreen.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.654: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://settings.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.654: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://gallery.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.664: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://system.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.674: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://email.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.684: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://clock.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.694: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://camera.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.704: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://communications.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.724: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://calendar.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.724: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://bluetooth.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.734: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://video.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.744: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://music.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.755: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://pdfjs.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.755: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://wallpaper.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.765: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://keyboard.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:54.785: ERROR/GeckoConsole(109): [JavaScript Error: "not well-formed" {file: "app://sms.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 23:49:55.575: ERROR/GeckoConsole(109): AUS:SVC Checker:onProgress - 604/604
12-03 23:49:55.585: ERROR/GeckoConsole(109): AUS:SVC Checker:onLoad - request completed downloading document
12-03 23:49:55.595: ERROR/GeckoConsole(109): AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
12-03 23:49:55.595: ERROR/GeckoConsole(109): AUS:SVC Checker:onLoad - number of updates available: 1
12-03 23:49:55.605: ERROR/GeckoConsole(109): AUS:SVC UpdateManager:_loadXMLFileIntoArray: XML file does not exist
12-03 23:49:55.605: ERROR/GeckoConsole(109): AUS:SVC gCanApplyUpdates - testing write access /data/local/update.test
12-03 23:49:55.605: ERROR/GeckoConsole(109): AUS:SVC gCanApplyUpdates - able to apply updates
12-03 23:49:55.615: ERROR/GeckoConsole(109): AUS:SVC UpdateService:_selectAndInstallUpdate - prompting because silent install is disabled

I am also seeing the same "not well formed" JS errors after FTE is concluded and I skip the tour:
12-03 16:01:25.520: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://calculator.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.540: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://browser.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.550: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://feedback.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.560: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://costcontrol.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.570: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://fm.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.580: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://homescreen.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.590: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://settings.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.590: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://gallery.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.600: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://system.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.610: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://email.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.620: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://clock.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.640: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://camera.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.650: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://communications.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.660: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://calendar.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.670: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://bluetooth.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.680: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://video.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.680: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://music.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.700: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://pdfjs.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.700: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://wallpaper.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.710: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://keyboard.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
12-03 16:01:25.720: ERROR/GeckoConsole(108): [JavaScript Error: "not well-formed" {file: "app://sms.gaiamobile.org/manifest.webapp" line: 1 column: 1 source: "{"}]
(Reporter)

Updated

5 years ago
blocking-basecamp: --- → ?
This is benign, but annoying and misleading.
Flags: needinfo?(fabrice)
Whiteboard: dupeme
I pushed a fixed earlier today: https://hg.mozilla.org/integration/mozilla-inbound/rev/abcf9d5fd503#l2.97

This will be in tomorrow's nightlies
Flags: needinfo?(fabrice)
Status: NEW → RESOLVED
blocking-basecamp: ? → ---
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 816149

Updated

4 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.